Ford Mustang Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
58 Posts
Discussion Starter #1
i have an 02 gt with no cats, h-pipe, flowmasters, 75mm throttle body, and cold air intake.

here is the problem, the car will randomly die at idle but it will start right back up, also sometimes ill start the car and it will make a loud popping sound (almost like a back fire) and then die but restart i have changed the spark plugs but not the coils, and fuel filter and the battery was replaced a year ago. Im wondering if this is due to the car running rich because of the larger throttle body and no cats. Ive read/heard to do an sct tune on the car and it should fix these issues. Or maybe this is something completely different. maybe a cam/crank sensor??

if anyone has any idea or suggestion please feel free to let me know what you did to correct this problem. Thanks


2002 gt, 75mm throttle body, bbk cold air, bassani h pipe, flowmasteres, steeda short throw shifter, fr500 rims 275/40/17 and 315/35/17, and rear window louvers
 

·
Registered
Joined
·
8,704 Posts
Without having something hooked up to the car to monitor air/fuel ratio I wouldn't jump to any conclusions. Is your check engine light on? Sounds like it could be EGR related, but that would only be speculation without a cel to back it up. The other sensors you mentioned would also trip the cel. Having no cats, and no tune or MIL eliminators to turn off the rear O2's would also trip the cel. Check for potential vacuum leaks and have your codes read is where I would start. Your only other option really is to blindly start throwing parts at it which I do not reccomend.
 
1 - 2 of 2 Posts
Top