Ford Mustang Forum banner

Status
Not open for further replies.
1 - 11 of 11 Posts

·
Registered
Joined
·
162 Posts
Discussion Starter · #1 ·
Well the passed few days when I get up to leave, the car starts up fine most of the time but by the time I back out the drive and get to the end of my road, the car dies when I start to slow down to stop. It has done that a few times. But this morning it actually stumbled and acted like it wanted to die so I revved it a little and it just didnt sound quite right. So as I was backing down the drive it was stumbling more and just running rough. So I revved it more as I coasted out the drive. Then I took off down the road wanting to get it revving and it seemed to be fine but before I got to the end of my road after I had let off the gas it started to not sound right again, like it wanted to start running rough again. I think it was just since its started getting a little chilly outside that this started if that helps. What is wrong?
 

·
Registered
Joined
·
93 Posts
87_5point0 said:
Well the passed few days when I get up to leave, the car starts up fine most of the time but by the time I back out the drive and get to the end of my road, the car dies when I start to slow down to stop. It has done that a few times. But this morning it actually stumbled and acted like it wanted to die so I revved it a little and it just didnt sound quite right. So as I was backing down the drive it was stumbling more and just running rough. So I revved it more as I coasted out the drive. Then I took off down the road wanting to get it revving and it seemed to be fine but before I got to the end of my road after I had let off the gas it started to not sound right again, like it wanted to start running rough again. I think it was just since its started getting a little chilly outside that this started if that helps. What is wrong?
I have the same problems like that when I run premium gas. I down graded to mid grade and I let her warm up about 5-10 min before taking off and everything is fine.
 

·
Registered
Joined
·
701 Posts
Does it drop below 500 RPM when "running rough"?
If that would be related to RPM's I wolud check, replace the IAC.
 

·
Registered
Joined
·
2,579 Posts
Idle Air Control Valve. It's always the idle air control valve.
 
G

·
Monkey Boy said:
Idle Air Control Valve. It's always the idle air control valve.
When i get some free time i am about to make a sticky on this. Its been told a thousand times! lol :eyepoppin
 

·
Registered
Joined
·
162 Posts
Discussion Starter · #6 ·
dallas02GT said:
I have the same problems like that when I run premium gas. I down graded to mid grade and I let her warm up about 5-10 min before taking off and everything is fine.
Well I run premuim in it because I have the Diablo tune in it and I dont want it to be detonating. Come to think of it, a 2002 does have knock sensors on it doesnt it or does it????
 

·
Registered
Joined
·
2,579 Posts
mbhmustang1998 said:
When i get some free time i am about to make a sticky on this. Its been told a thousand times! lol :eyepoppin
Thank you!!!!!!!!!!! :happyhapp
 

·
Registered
Joined
·
162 Posts
Discussion Starter · #8 ·
OK that might be true, but explain this. Me, my buddy and his gf were rolling down the bypass with my other buddy in the 5.0 behind us in hot pursuit(but failing miserably). We got going 110-120 and I let off. THen I pushed the clutch in and pulled it down into neutral and I just left it there. Then we coasted down to about 100 when I went to pass a car, I realized that the car had just stopped running. Well without them even noticing, I got it started back up, so it was a slick move. But why did it just up and die? We had just come from the bowling alley and we had been driving a few miles to get to the bypass, so why would this still happen if its the iac? Now granted I was in neutral coasting so I'm sure my rpms dropped way back down, maybe near idle, but still. I havent actually had the car on the dyno or anything since I put on the cai or the tb and plenum. But hell they've been on a couple weeks and this just started happening. Hell I drove down to Bowling Green to the NMRA World Finals and drove around the entire time I was there and no problem. Drove to and from work and all around town no problem. But now this just all of a sudden. Is it still the iac???
 

·
Registered
Joined
·
2,579 Posts
Dude, that incident screams IAC valve. You put it in neutral, you weren't pressing the gas, and all of a sudden it dies. It's the IAC valve. Never contradict the great Monkey Boy when it comes to Ford idling problems! :laughlitt :worship
 

·
Registered
Joined
·
701 Posts
Monkey Boy said:
Dude, that incident screams IAC valve. You put it in neutral, you weren't pressing the gas, and all of a sudden it dies. It's the IAC valve. Never contradict the great Monkey Boy when it comes to Ford idling problems! :laughlitt :worship
Sweet.... You're quite self confident... :eyepoppin
 
1 - 11 of 11 Posts
Status
Not open for further replies.
Top