Ford Mustang Forum banner
Status
Not open for further replies.
1 - 10 of 10 Posts

· Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
The codes are P401 & P402 on the OBD reading and they say insufficient flow. I already changed the EGR valve. What else can I do? Please help if you can. Its a 96
 

· Banned
Joined
·
2,184 Posts
You may want to replace the DPFE sensor. Mine went bad on my Windstar and the $50 replacement from Advance Auto Parts fixed it right up :smoke: . Of course it was running horribly, stuttering and what not, getting 10 MPG.
 

· Registered
Joined
·
11,101 Posts
rtrejo77 said:
Would a dirty MAF really make the code come up EGR flow insufficient? Is it just a guess or how sure are you.
I don't know the codes. a MAF shouldn't cause problems with the EGR. If it's EGR flow, then it's a sticky valve.
 

· Registered
Joined
·
8 Posts
Discussion Starter · #7 ·
The car runns fine and I just had the EGR valve replaced a day ago because I thought it might be a sticky valve. It used to read both insufficient and exessive flow but now with the new valve it just reads insufficient
 

· Registered
Joined
·
11,101 Posts
rtrejo77 said:
The car runns fine and I just had the EGR valve replaced a day ago because I thought it might be a sticky valve. It used to read both insufficient and exessive flow but now with the new valve it just reads insufficient
did you disconnect the battery?
 

· Registered
Joined
·
11,101 Posts
rtrejo77 said:
No I erased the codes with an OBD II
Before you go any further, disconnect the battery for a few minutes and reconnect to see if it comes up again.
 
1 - 10 of 10 Posts
Status
Not open for further replies.
Top