Ford Mustang Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have a 1993 Mustang gt foxbody with a 302 HO I just replaced the Dis module because my car would spit and sputter and sometimes backfire down the hwy. While replacing the module with Dis pulled out a friend went underneath to mark 10 degrees before TDC. After installing Dis back I set the timing from his marks and drove it spit and sputter gone but would backfire when pushing in clutch to shift. I left it alone to recheck later at home 35 miles away. It drove good for about 10 miles then went to missing like crazy I just did make it home it didn't have much power at all and run like it was running on 2 cylinders and would backfire in intake. I got home checked timing again and noticed he marked 10 degrees after TDC it was pretty rusty to see at the time anyways I reset timing all power is back but still got miss but no spits and sputters like before. My question is could I have damaged the engine or is it more likely I just fouled a plug any advise is appreciated Thanks
 
J

·
Guest
Joined
·
0 Posts
Unfortunately yes you could have messed up a lot of things driving that far with timing that retarded (O2 sensors, cats, burned valves, etc.). But it's most likely what you say, pull your plugs and check their condition / replace if fouled. No reason to sweat it until you check those.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Thank you I appreciate it crossing my fingers that the plugs is all that's bad. Also if the plugs is all that's bad and I don't have to replace heads or worse (knock on wood) my valve stem seals are leaking bye a little causing a little smoke after a 20-30 mile run whats the best valve stem seals to use in these cars? I've tried lucas and it seems to help for a week maybe then it starts again or is there something else additive wise you would suggest using?
 

·
Registered
Joined
·
864 Posts
2sd that check your plugs
 
1 - 4 of 4 Posts
Top