Ford Mustang Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1
1986 5.0 LX, has been stored in my grandfather garage for a few years started it up and took it for a drive. When above idle a steady thin drip of coolant was leaking into the passenger foot well, any suggestions to what it could be? heater core?
 

·
Registered
Joined
·
1,872 Posts
The dreaded leaking heater core. $30 part, many labor hours to replace. Dash has to be dropped. There are a bunch of write-ups on how to swap it out. Latemodelrestoration supply has a great write up. Good 6-8 hours for DIY. Expensive to pay someone to do it.

If you don't need the heater or want to stop the leak short term you can bypass the heater core with a short hose on the heater tube that runs along the intake.

If you have to replace the heater core and you still have A/C it's a good time to swap the evaporator too.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #3
Thanks! i'll make sure to do a search from here on out thanks for the help!
 

·
Registered
Joined
·
3,130 Posts
Plus one on what stangdawg said.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #5
well i have a new problem today, the alternator and battery are dead so they are on my list of things to change but when i jump the car it starts and idles fine, but every time i press the clutch down it stalls. Do you think its a short from the coolant running through the dash? if so how would i be able to diagnose?
 

·
Registered
Joined
·
3,130 Posts
well i have a new problem today, the alternator and battery are dead so they are on my list of things to change but when i jump the car it starts and idles fine, but every time i press the clutch down it stalls. Do you think its a short from the coolant running through the dash? if so how would i be able to diagnose?
First get you a good alternator. Sounds like the battery holding a charge and while the car is idling it is running strickly off the battery and when you ready to drive battery is back drained.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #7
checked that, alternator is fine battery was dead though haven't put a new one in yet hope that solves the problem
 
1 - 7 of 7 Posts
Top