Ford Mustang Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
170 Posts
Discussion Starter #1
I was rebuilding my carb when i noticed this crack in the accelerator pump cover(1st picture). My question is, does this pose a problem for me? If it does what do you recommend i do to fix it? Also in the 3rd picture, there appears to be a tube that looks like it was cut then pinched. Is there a reason for this? I will be putting this on my automatic I6.(if it matters) I know the pictures suck, cell phone...
I circled the crack in the last 2 pictures, its not a clean brake all the way through, just a small crack.
 

Attachments

·
Registered
Joined
·
4,555 Posts
As long as the accelerator pump doesn't leak, it should be okay, you might try some super glue, it reacts with aluminum, I haven't tried it on carb pieces though. Good Luck.
 

·
Registered
Joined
·
288 Posts
I don't think the crack is going to cause you any issue. The diaphram is right behind that, and the accel pump cover is holding that diaphram on. The crack doesnt look all that bad to affect operation.

The second thing, the "tube" you think has been krimped, relax on that one, it is just the way that they krimp the ends on the buttery fly thing that you screw the air cleaner cover onto. That is how it is held to the carb. No worry, normal.
 

·
Registered
Joined
·
2,624 Posts
That won't cause you any problems. Alot of original autolite 1100's have that problem. The aluminum pump cover warps and then cracks over time.
 

·
Registered
Joined
·
197 Posts
The place where the crimped tube is should have a screw in it. There should be a screw on each side of the stud holder for the air cleaner. Someone may have stripped the screw and put that cheap pop rivet in there.
 

·
Registered
Joined
·
2,624 Posts
The place where the crimped tube is should have a screw in it. There should be a screw on each side of the stud holder for the air cleaner. Someone may have stripped the screw and put that cheap pop rivet in there.
WRONG. The originals DID NOT have screws. They had those little pins (they aren't rivets) that held the air cleaner bracket in. All of my autolite 1100s (I've had several, all originals) had those pins. The only time that one had screws is when I over tightened the wing nut and it broke the pin, so I had to put screws in (I was on the highway, I needed a fix).
 
1 - 6 of 6 Posts
Top