Ford Mustang Forum banner
Status
Not open for further replies.
1 - 3 of 3 Posts

·
Registered
Joined
·
144 Posts
Discussion Starter · #1 ·
Where do I start. Ok so i have had no A/C and my cooling fan stopped working. My fan would stay on when I had the temp senor unplugged and thats how I kept it so the car would not over heat since it is un godly hot here in florida. I assumed the problem was the ccrm from all that I have read. So i replaced the ccrm and had my a/c recharged. Now my fan will go on when I turn on the A/C but if I unplug the temp sensor the A/C clutch will turn off and the fan will stay on, also my A/C is still not blowing cold, no leaks were found with the dye test. What the hell is going on here? Im so lost. please help. thanks guys.
 

·
Registered
Joined
·
411 Posts
Check your a/c clutch,this would cause some of these issues.
 

·
Registered
Joined
·
144 Posts
Discussion Starter · #3 ·
Update:

I was able to get the a/c working.....sort of. The clutch would spin and air would come out cold but only when the car is in motion. The clutch did not cycle on and off it just stayed on and it had a sort of clicking sound to it. Well yesterday I was driving with the a/c on and the car started to buc real bad, my rpm's would not come down, they stayed around 2500 even when stopped and the air started to go warm. I turned the car off and back on and it ran fine but now my a/c blows warm all the time. The a/c clutch kicks on when you first start the car and spins for about 5 sec and then stops and does not come back on. Do I need a new clutch or is it something deeper?
 
1 - 3 of 3 Posts
Status
Not open for further replies.
Top