Ford Mustang Forum banner

1 - 20 of 47 Posts

·
Registered
Joined
·
53 Posts
Discussion Starter #1
So had my car at the dearlship for trans trouble (MT-82)brembo. Ford replaced the clutch, and the pressure plate; they also said the bolts had back out causing the problem. Get the car two days ago and no problems driving to work, which is about 28 miles, but not getting on it or any kind of crazy driving. On the way home i was like im gonna get on it a bit.... I did and the check engine light starts flashing at me, get home read the codes and its miss firing in cylinder 2 and 3. I cleared the codes and was thinking it may have been from lower octane(from dealer) Ive been runing 93 octane. same code comes back and it seems everytime i get on it, the engine light will flash and the same codes keep coming up.

The center console feels really hot when driving around. I have never felt it get that hot beore. It feels like a heater from the center console. Im thinking they removed the heat sheild, or the trans is getting really hot.

What do u guys think the problem could be?
 

·
Registered
Joined
·
1,872 Posts
Do you have a tune on the car, if so what brand?
 

·
Registered
Joined
·
53 Posts
Discussion Starter #3
had a tune from bama...tune sent out after the date they specified as messing with the knock sensor. but changed back before going to dealer. also took the CAI off. currently stock and drove around 60 miles before taking the car back in to the dealer...so as of right now im completley stock.
 

·
Registered
Joined
·
47 Posts
I had the same issue (with misfire and clutch). Don't worry, you just have to relearn crankshaft sensor. Only Ford dealer can do it. This procedure takes about 3-4 minutes.

Don't know why, but this happens only with cars with bad PP bolts.

21474 SOME VEHICLES COULD EXHIBIT MISFIRE CODES AFTER CERTAIN REPAIRS - MULTIPLE VEHICLE LINES
SOME VEHICLES EQUIPPED WITH ON BOARD DIAGNSTICS (OBD) MISFIRE MONITOR NEUTRAL PROFILE LEARNING CAPABILITIES MAY EXPERIENCE THE MIL ILLUMINATING ACCOMPANIED BY ONE OR MORE ENGINE MISFIRE CODES P030X IF THE CRANKSHAFT POSITION SENSOR PROFILE (MP_LRN) IS NOT RELEARNED FOLLOWING CERTAIN HARD ENGINE REPAIRS. THE MP_LRN DATA IS NO LONGER CLEARED WITH A KAM RESET OR BATTERY DISCONNECT. REPAIRS THAT REQUIRE RELEARNING THE MP_LRN DATA: CRANK SENSOR,CRANK SENSOR, TRIGGER WHEEL, ENGINE TIMING, DAMPER, CRANKSHAFT, ENGINE, FLYWHEEL/FLEXPLATE, CLUTCH (MANUAL TRANS), PRESSURE PLATE (MANUAL TRANS),TORQUE CONVERTER (AUTO TRANS). FROM THE IDS TOOLBOX SELECT "POWERTRAIN", THEN "SERVICE FUNCTIONS", THEN "MISFIRE MONITOR NEUTRAL PROFILE CORRECTION" AND FOLLOW THE PROMPTS.
EFFECTIVE DATE: 08/26/2010

21463 2010-2011 5.0L/6.2L - MISFIRE CODES P0300-P0316
SOME 2011 MUSTANG VEHICLES EQUIPPED WITH A 5.0L ENGINE AND 2010 F150 AND 2011 SUPER DUTY VEHICLES EQUIPPED WITH A 6.2L ENGINE MAY EXHIBIT THE MALFUNCTION INDICATOR LAMP ILLUMINATING ACCOMPANIED BY ONE OR MORE DIAGNOSTIC TROUBLE CODES P0300 THROUGH P0316. IT IS RECOMMENDED THAT THE CRANKSHAFT POSITION SENSOR PROFILE (MP_LRN) BE RELEARNED PRIOR TO PERFORMING THE PC/ED PINPOINT TESTS FOR THESE CODES. FROM THE IDS TOOLBOX SELECT "POWERTRAIN", THEN "SERVICE FUNCTIONS", THEN "MISFIRE MONITOR NEUTRAL PROFILE CORRECTION" AND FOLLOW THE PROMPTS. IF ONE OR MORE OF THE MISFIRE CODES RETURN AFTER PERFORMING THE RELEARN PROCEDURE, REFER TO THE PC/ED PINPOINT TESTS.
EFFECTIVE DATE: 08/17/2010
 

·
Registered
Joined
·
407 Posts
crankshaft relearn

crankshaft relearn and misfire relearn take a few minutes with the appropriate IDS tool. I was having the same problem since I changed my clutch out.
 

·
Registered
Joined
·
159 Posts
crankshaft relearn and misfire relearn take a few minutes with the appropriate IDS tool. I was having the same problem since I changed my clutch out.
Did you have to take the car to the dealership? I assume the IDS tool is some type of diag tool, which is why I ask. I would had to have to take the car into the dealer because I changed my clutch.
 

·
Registered
Joined
·
47 Posts
Yes, you have to go to your dealer after changing clutch in case of cel.
 

·
Registered
Joined
·
1,305 Posts
I once had a crankshaft position learn code come up when installing the FRPP ProCal tune. went away after a few blips of throttle to 4k rpm.
 

·
Registered
Joined
·
407 Posts
IDS tool

IDS is a ford specific diagnostic tools; my buddy owns a large shop and has this tool. I'd imagine most large shops would have one.
 

·
Registered
Joined
·
66 Posts
While you're there see if you can talk to the tech. Tell him to RTFM next time- he missed that one. Of course it is one of their new 'better ideas' to have to relearn the crank sensor when the clutch is changed.
 

·
Registered
Joined
·
146 Posts
yea had the same issue on my car when they changed the clutch , after the re-learn shes good to go
 

·
Registered
Joined
·
937 Posts
It's pretty bad when you mention "Internet Forum" to a Dealership they roll their eyes but if the information wasn't here, would they even know what to do? It's the Customer that seems to know more about the car. :gringreen
 

·
Registered
Joined
·
53 Posts
Discussion Starter #16
Got the car back today....problem seems to be fixed. Heres hoping I dont have anymore issues with the car. Thanks for the info i told the service writer about the crankshaft sensor.. they checked into it, he called me back and that was the problem.
 

·
Premium Member
Joined
·
575 Posts
trey,
post some photos of your pony. It looks like a brembo car... Load up your photo gallery.. I'd like to see what she looks like all the way around.
 

·
Registered
Joined
·
131 Posts
Got the car back today....problem seems to be fixed. Heres hoping I dont have anymore issues with the car. Thanks for the info i told the service writer about the crankshaft sensor.. they checked into it, he called me back and that was the problem.
How much did you charge the service writer for doing his freakin' job for him?
 

·
Registered
Joined
·
585 Posts
So I am experiencing this same exact problem and very glad I just found this thread. I don't know what the code is but I get the flashing CEL and eventually the light stays solid. Same exact symptom with the center console getting really hot after this happens. I had to bring in my car because of an oil leak, which turned out to be coming from the main seal. They had to drop the transmission and replace the seal so I'm assuming this would also fall in the same category of repairs listed in what Teen_Spirit posted.

When the above happens if I disconnect the battery and don't do any spirited driving everything is fine but if for example I downshift and get on it attempting to make a quick pass on the highway I get the flashing CEL and it will eventually stay solid then the excessive heat from the center console.

Man, this repair has been such a nightmare with so many other things being screwed up (see here). You would think the techs know they need to do this after performing certain types of repair.

trey799 has your problem been solved for good? No more flashing/solid CEL and heat?
 

·
Registered
Joined
·
53 Posts
Discussion Starter #20
@chris....the car is pretty much stock as far as cosmetic..but give me a few days ill post more pics....to the other poster that is having problems...the car is running good now...no problems with codes anymore. It really was a simple fix as far as relearning the crankshaft sensor, but I still notice that the trans feels hot around the driver console. I dont think their is a problem but i have never noticed it get that hot before. I still say to my self man it feels hot around the center console when driving. Im really thinking they took out the heat sheild around the console, and didnt put it back in. Im going to try and get under the car and see if i can see anything. Im on vacation right now so when i get back i will look at it
 
1 - 20 of 47 Posts
Top