Ford Mustang Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hello all AFM users. I have been stalking you guys for a while and finally decided to make an account to post a question that has recently come up.

I recently supercharged my v6 mustang and have been having an absolute blast with it. I highly recommend the Procharger as their kit was so easy to install on my 2012 i was able to do it myself. (I am 19 with little car experience).

The question I have is that while making a turn in a parking lot my SERVICE ADVANCETRAC light came on. After searching online i found this could be related to many issues from ABS control module to the electric steering sensor being faulty. The list goes on. I just recieved a phone call from ford today and the manager told me that the Service AdvanceTrac light is directly related to my supercharger and that i would not be able to remove it. He also said another mustang was just there for the same reason and it was supercharged as well. This is a reason that I have NEVER heard before. Apparently the sensor is directly tied into something the supercharger affects but he could not tell me what it was.

Would any fellow Procharged stangs like to chime in? it makes me wary not having any form of traction control.
 

·
Registered
Joined
·
16 Posts
Before I got my 07 I was looking into buying a 05 supercharged with the 7.4k$ xcharger kit from a family member. He let me keep it to see if i wanted it for a week and it had a light in the dash that constantly came on. He said it was the mass air flow sensor because the supercharger. I don't know if that has anything to do with your problem too but i would definitely not rule it out.
 

·
Registered
Joined
·
1,078 Posts
I'm not procharged but i ordered a tune from MPT. I marked the 'traction control on or traction control off' box wrong. I got the Service Advancetrac light. I told MPT about my problem and they sent me another tune with no cost. Never had the light come back on since :)
 

·
Registered
Joined
·
45 Posts
You more than likely just need to reset your advance track system. While at a stop with your foot applied to the brakes, hold your traction control button until until you see advance track turn off. Turn it back on and then turn the car off, restart the car and you should be fine. If not, then have a tuner turn it off for you.
 

·
Registered
Joined
·
1,314 Posts
procharged for over a year with no advance Trac issues. works as advertised when on. think your dealer is clueless.
Yeah... I have to call
nbs.gif
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #7 ·
You more than likely just need to reset your advance track system. While at a stop with your foot applied to the brakes, hold your traction control button until until you see advance track turn off. Turn it back on and then turn the car off, restart the car and you should be fine. If not, then have a tuner turn it off for you.
Unfortunately the traction control and advance trac options are useless at the moment. I can hold down the tsc as long as i want and nothing happens :/
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #8 ·
I'm not procharged but i ordered a tune from MPT. I marked the 'traction control on or traction control off' box wrong. I got the Service Advancetrac light. I told MPT about my problem and they sent me another tune with no cost. Never had the light come back on since :)
That sounds like a great idea. I will be contacting my tuner after i get my car back to see if its in the tune. Did your tune cause the light to come on immediately after flashing your car or did it take some driving before it appeared?
 

·
Registered
Joined
·
190 Posts
Is the trac. Control light on the button lit up? I took mine to the dealer for service and they unhooked the connecter and I guess forgot to plug it back up . I had to take apart the shifter console area and plug it back in. Not sure if this would be related to your problem.
 

·
Registered
Joined
·
1,078 Posts
That sounds like a great idea. I will be contacting my tuner after i get my car back to see if its in the tune. Did your tune cause the light to come on immediately after flashing your car or did it take some driving before it appeared?

It came on within a few miles of driving. No matter what i did with the traction control (on or off) nothing would change. MPT told me i should have ordered the tune with the traction control 'on' box checked (i may have this backwards, i can't remember). After MPT changed the traction control setting, they sent me a (free) new tune. The 'Service Advancetrac' light has never come back on. :)
 
1 - 10 of 10 Posts
Top