Ford Mustang Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter · #1 ·
This is for those who have a GT in California and equiped with a Steeda CAI/Predator. I live in the Bay Area and been having moderate pinging problems. I'm wondering if others out there been having these same issues on hot days? I got the timing backed off a whopping 25% in the 4-7K range and still pings a little. I'm hoping this isn't just me, tried several different fuels to no avail :-(

Bill
 

·
Registered
Joined
·
829 Posts
Stangdood said:
This is for those who have a GT in California and equiped with a Steeda CAI/Predator. I live in the Bay Area and been having moderate pinging problems. I'm wondering if others out there been having these same issues on hot days? I got the timing backed off a whopping 25% in the 4-7K range and still pings a little. I'm hoping this isn't just me, tried several different fuels to no avail :-(

Bill
Engine has two knock sensors. I suggest something amiss with their operation, also take a look at the A/F , might be leaning out too much. Don't run it hard until you get this fixed as it will wreck your rod bearings fast. Russ
 

·
Registered
Joined
·
151 Posts
DILURKER, I live in LA as well and I hope to see you down the road. Who's your tuner may I ask?
 

·
Registered
Joined
·
80 Posts
The tune that's in there now is from Steeda. I ordered my CAI and Predator together and I used the 91 octane/CAI tune they loaded for me. No complaints at all, except for the increased idle speed (about 100 rpm higher).

My car is currently having some parts installed and head work done at Superior Automotive in Anaheim, and Shawn Ellis (SoCal Tuning) is going to tune her when they're done.
 

·
Registered
Joined
·
151 Posts
DELURKER where is SOCAL tuning located?
 

·
Registered
Joined
·
24 Posts
Discussion Starter · #8 ·
delurker said:
Steeda CAI/Predator in LA and no ping. This may sound like a dumb question, but are you sure you're using the right tune?
Yes, using the right tune. 3 months ago it pulled 282 on the dyno with a fairly flat 13 A/F ratio, no pinging then, it was cool outside. GIG4FUN brings up an interesting point, why didn't the knock sensors work?? Got me puzzled!!

Bill
 
1 - 8 of 8 Posts
Top