Ford Mustang Forum banner

Status
Not open for further replies.
1 - 14 of 14 Posts

·
Registered
Joined
·
701 Posts
Discussion Starter #1
Guys

I have a stock 2000 GT. Last week end I was cruisin for about 20 minutes on I-84 and a guy in an eclipse pulled up and wanted to race.

Useless to say that the stock eclipse couldn't catch up...

BUT: While I was accelerating I heared my motor pinging like crazy. I really felt sorry for my motor, but I had to win.
Of course, now I am lookig for the cause for the pinging.
My first thought was that with the motor "cruising", the Intake got a lot of heat because of the EGR is feedig hot exhaust gases into the Intake. And when I floored it, the air just got to much heat by flowing thru the Intake and caused the pinging. Gas wise, I am only running mid grade, brand name gas.

Could this Problem be solved with a EGR elimination (Diablo Sport)?

Thanks for your inputs.
 

·
Registered
Joined
·
701 Posts
Discussion Starter #2
Additional information:
Last night I hooked the EGR valve off and went cruisin' on the same interstate.
When I accelerated:
Same f$%!ing problem - lots of pinging!
I stopped at a rest area and checked the intake temperature. Nice and cold, no heat by the EGR valve.

MAN, can some one tell me why I could have pinging problems alltough I run 89 octane fuel!!!

Could I have bought my car with a flashed ECU with what ever kind of Information in it (Superchip, Hypertech, Diablo Sport etc.)?

HELP IS DEFINITELY APPRECIATED...
 

·
Registered
Joined
·
4,524 Posts
Pinging can be caused by many factors

1. Exposed K&N filter under the hood (sucking in hot air) (CAIs help considerably)
2. Bad fuel (switch to other brand or higher octane)
3. Failing fuel component (filter, injector, pump)
4. DIRTY MAF (very common when using oiled filters).
5. Carbon deposits on valves/combustion chambers
6. Wrong EEC calibration...say you got a car that was sold with a high altitude calibration and you use it at a lower altitude.

Check the first four.
 

·
Registered
Joined
·
701 Posts
Discussion Starter #4
Thanks for your Input Robert

2K miles ago I checked /cleaned:
MAF, changed fuel filter, run 2 bottles of STP Fuel system cleaner, replaced air filter with a stock Ford one (no CAI) and replaced Spark plugs with the OE Motorcraft ones.
Since I am only using Shell, Exxon and Mobil Gas it should cause no problems.

I am just going to run an other two bottles of fuel system cleaner. If that does not help out, I am probabely just going to see my dealership.

THX a lot
 

·
Registered
Joined
·
701 Posts
Discussion Starter #5
Update:

I had my car checked at the Dealership last friday.
The pre owner definitely screwed around with the data in the ECU.
Fortunately the dealership found a "Ford Update" in their programmers and set it back to original specs. Sweet sweet 87 Octane is in my gas tank again. No pinging, great throttle response etc.

Now I am thinking about getting a diablo sport, and if i don't like it, I can still set it back to Ford specs.

cheers!
 

·
Registered
Joined
·
3 Posts
I personally would go with the STC, rather than Diablo.
 

·
Registered
Joined
·
5,910 Posts
I think he got it fixed.
 

·
Registered
Joined
·
5,910 Posts
Hit the autobahn yet?
 

·
Registered
Joined
·
701 Posts
Discussion Starter #10

Going to pick up the Stang this Friday.
She's been waiting for me for about a week now. I hope she's not been parked next to a Chevy…

530 miles on the autobahn...I can't wait!
 

·
Registered
Joined
·
5,910 Posts
So that's what??? A 4 and a half hour road trip?? Dude you MUST get video or at least some pics.
 

·
Registered
Joined
·
701 Posts
Discussion Starter #12
I have a video, just need to convert it from the camera phone format into the mpeg format.
It was sweet! But with the traffic, it wasn't safe to go faster than about 115 to 125 mph. Still pretty cool doing 120 on cruise control for a couple of minutes.
 

·
Registered
Joined
·
5,910 Posts
that's so awesome. one day I'm going over there for the specific purpose of getting on the autobahn.
 
1 - 14 of 14 Posts
Status
Not open for further replies.
Top