Ford Mustang Forum banner
Status
Not open for further replies.
1 - 4 of 4 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
So i got a 1996 mustang gt the other day, and i put a clutch quadrant, firewall adjuster, and an adjustable clutch cable... well the quadrant wore through some wires up under the dash, so i fixed those, but before that it was blowin fuses and i couldnt figure out why til i found out about the wires... well now my speedo doesnt work, anti theft doesnt work, stereo doesnt work, and the cruise dont work... all the fuses are good ive checked all of them, but i was wondering if theres any relays or anything i should check out, any help would be appreciated... Thanks
 

·
Registered
Joined
·
16 Posts
So i got a 1996 mustang gt the other day, and i put a clutch quadrant, firewall adjuster, and an adjustable clutch cable... well the quadrant wore through some wires up under the dash, so i fixed those, but before that it was blowin fuses and i couldnt figure out why til i found out about the wires... well now my speedo doesnt work, anti theft doesnt work, stereo doesnt work, and the cruise dont work... all the fuses are good ive checked all of them, but i was wondering if theres any relays or anything i should check out, any help would be appreciated... Thanks
Just wondering exactly what you did to "fix" those wires under the dash?? And check your factory manual for the relays that operate those things.. Did you check the fuses under the hood?
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #3 ·
i cut the bad section out, soldered in a new section and used shrink wrap on it to fix the section that was bad, and ive checked every fuse on the car... even the ones that run the stuff not working, ive checked manuals and looked at everything... i dont get it
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top