Ford Mustang Forum banner

Status
Not open for further replies.
1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I have a 2000 GT. I was recently re-installing the factory radio. I had to move the a/c controls back to the original location. After I finished the installation, the air was hot. I moved the control to cool and the car turned off. I can no longer start the car.

Symptoms are as follows:

When I press the brake, the dome light shuts off.
My headlamps don't work.
No fuses are blown.
Battery is fully charged.
I can hear the starter ticking, but engine won't crank.

After several fuse pullings and checks, there is a black box next to the passenger fuse box that has a relay that keeps clicking off and on.

When I turn the key in the back position, the interior beep to let you know the doors with the key rapidly beeps with the before mentioned relay clicking.

Any suggestions?
 

·
Registered
Joined
·
5,907 Posts
Wow, sounds like there are multiple faults there. I can't think of anything offhand that includes the starter, dome light and headlights. This is a situation where I would definitely consider taking it in to be repaired.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
I am going to try a new battery today. I have no way of testing the cranking amps of my battery. I'll post the results.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
Wooo Hoooo!

I replaced the battery and it worked. The only problem now is that I have to go to work... :doh:
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top