Ford Mustang Forum banner

emission help

1126 Views 6 Replies 4 Participants Last post by  kscoyote
Looking for anyone with emissions knowledge.

Subject: 99 3.8l 96660 miles

problem: AIR Pump- has been replaced with a used one.

Engine light will not go out unless reset by batttery disconnection. Unfortunately light will only stay out for about a day, then comes back on, emission test today failed due to lack of run time from battery disconnection. Inspector states car needs to be run for three days with out power interruption. This is a PA state emission inspection.

Anyone in the Pottstown, PA area that might know or maybe need to get a better look at it is welcome.
:sosad:
Status
Not open for further replies.
1 - 2 of 2 Posts
I'm not sure what the question is, but I think it has to do with the CEL?

Did you check to make sure the used pump worked?
shock400 said:
Looking for anyone with emissions knowledge.

Subject: 99 3.8l 96660 miles

problem: AIR Pump- has been replaced with a used one.

Engine light will not go out unless reset by batttery disconnection. Unfortunately light will only stay out for about a day, then comes back on, emission test today failed due to lack of run time from battery disconnection. Inspector states car needs to be run for three days with out power interruption. This is a PA state emission inspection.

Anyone in the Pottstown, PA area that might know or maybe need to get a better look at it is welcome.
:sosad:
oh! Ok!

Probably an oxygen sensor. May have gotten fouled while the pump was out.
1 - 2 of 2 Posts
Status
Not open for further replies.
Top