Ford Mustang Forum banner

1 - 20 of 24 Posts

·
Registered
Joined
·
478 Posts
Discussion Starter #1
Anyone else noticing that their Ford engine cover (plenum) is rubbing against the hood insulation. Any ideas for fixes?
 

·
Registered
Joined
·
2,560 Posts
I think any CAI unit will hit the hood insulation also. I wouldn't worry, but I'll have to look at mine now!
 

·
Registered
Joined
·
239 Posts
sonny1213 said:
I think any CAI unit will hit the hood insulation also. I wouldn't worry, but I'll have to look at mine now!
UMMMMMMMMMM. He said Plenum cover(engine cover):rolleyes: :laugh:
 

·
Registered
Joined
·
239 Posts
I haven't really lookewd to see if mine was hitting or not, But if it is I'll repaint...
 

·
Registered
Joined
·
239 Posts
6 days does not a week make.....You said CAI(cold air intake) not the same thing... :p
 

·
Registered
Joined
·
1,315 Posts
I noticed mine was rubbing also... I took the insulation off... The paint underneath the insulation wasn't too bad...
 

·
Registered
Joined
·
2,560 Posts
fishingjts said:
I noticed mine was rubbing also... I took the insulation off... The paint underneath the insulation wasn't too bad...
Is it only the Ford cover that rubs? I have the other one that came out last year.
Hey Trick---:blink: :laugh:
 

·
Registered
Joined
·
787 Posts
AWWWW MAN!!!

One more thing to worry about...better yet.

Why worry when we can obsess..:happyhapp

I'll let you know if mine rubs. Had it only three days or so...
 

·
Registered
Joined
·
6 Posts
Yup, I noticed mine is also rubbing. I now have a line worn across the top of the cover. It's been on for about 3 weeks.
 

·
Registered
Joined
·
787 Posts
What da?

Any possible solutions guys?? Trimming the insulation (like with a sander?) and painting it so that it does not continue to crumble?

Where exactlly does it rub??
 

·
Registered
Joined
·
867 Posts
Interesting. I have the Ford cover and the double Steeda brace on top of that and neither rubs.
 

·
Registered
Joined
·
787 Posts
2horseowner said:
Interesting. I have the Ford cover and the double Steeda brace on top of that and neither rubs.
Yeah, that is interesting. Considering that the brace is at least 1/2 inch taller that the cover.
 

·
Registered
Joined
·
1,749 Posts
wonder if the 07's have that problem? if not, wonder whats different?:shrug
 

·
Registered
Joined
·
538 Posts
I hope I just didnt spend 300 bucks on a Midwest Auto air brushed plenum cover only for it to have friggin rub marks on it in a couple of weeks!!
What about my strut tower brace?? Will the tower brace clear the plenum cover??
 

·
Registered
Joined
·
478 Posts
Discussion Starter #17
HazMatLadder26 said:
I hope I just didnt spend 300 bucks on a Midwest Auto air brushed plenum cover only for it to have friggin rub marks on it in a couple of weeks!!
What about my strut tower brace?? Will the tower brace clear the plenum cover??

I have the Ford cover. I do not know what the differences are, but form just seeing pics, it looks like they mount differently.

I have read where you may have trouble with the strut clearing the cover, probably depends on the brand.
 

·
Registered
Joined
·
91 Posts
I have the Midwest cover and also have some black marks where it rubs. Unfortunatley I didn't find it until the damage was done. The insulation doesn't seem loose, so I would also be interested if anyone has a suggestion.
 

·
Registered
Joined
·
538 Posts
99vert said:
I have the Midwest cover and also have some black marks where it rubs. Unfortunatley I didn't find it until the damage was done. The insulation doesn't seem loose, so I would also be interested if anyone has a suggestion.
If you install a strut tower brace, the brace will keep the insulation from rubbing on the plenum cover. I would go with a single bar strut tower brace so the brace does not interfere too much with the visual you get from the plenum cover. I have a double bar tower brace and it kinda takes away from the graphics. Steeda makes a nice single bar for around 99 bucks. IMO. Good luck!
 

Attachments

·
Registered
Joined
·
100 Posts
Mine was rubbing too. I figured out that the insulation was sagging or flapping in the wind, so what I did was removed the insulation and then drilled two holes in the ribs of the braces that support the hood and then I installed a couple of those plastic push pins that I purchased at a local auto parts supply store. I'll take pictures tommorrow and post them for you guys.
 
1 - 20 of 24 Posts
Top