Ford Mustang Forum banner

Status
Not open for further replies.
1 - 7 of 7 Posts

·
Registered
Joined
·
105 Posts
Discussion Starter #1
So I'm going down the road today and I push the clutch in. To my amazement, the damned engine just shuts off. It kept doing this to me on and off all day. I'm wondering if my IAC is going bad, or if the ground that I don't have hooked up has anything to do with it.
 

·
Registered
Joined
·
40 Posts
yeah that happend to me too. It just shut off a couple times then the last time wouldnt start. I popped up the distributor cap and the rotor was snapped in half.... hmm. So i got a new cap and rotor, and it ran fine for about 10 miles then did it again. Popped the cap, another snapped rotor. Found out that the distributor bushing inside was worn letting the shaft wobble while it spun, which i guess through the rotor into the side terminals of the cap. Got a new distributor and it fixed the problem.
 

·
Registered
Joined
·
897 Posts
need to give more specifics,does it start right back up or do you need to wait for it to cool? does she stumble or just cut off? any hesitation?
 

·
Registered
Joined
·
105 Posts
Discussion Starter #5
She starts right back up after a clutch bump. It hesitates sometimes, but sometimes it just dies completely, immediately following depression of the clutch. I'm going to pull the dist off and see what's going on with that, and check all my wires.
 

·
Registered
Joined
·
47 Posts
my car is doing the same thing but like stingrey asked mines stumbles and pops and farts when it cools down its back to business as usual. I'm so frustrated with it i don't know what to do. then it wont do it for another 3 for days maybe even a week. i'll be watching this post i need help too.
 

·
Registered
Joined
·
9 Posts
I discovered that mine has a short somewhere in the wiring for the starter. Disconnect the black connector on your clutch switch and see if it still does it. If not, problem found.
 
1 - 7 of 7 Posts
Status
Not open for further replies.
Top