Ford Mustang Forum banner

Status
Not open for further replies.
1 - 7 of 7 Posts

·
Registered
Joined
·
38 Posts
Discussion Starter #1
ok so im goin to try to explain this the best i can, this is my first car its a 1989 mustang LX hatchback 2.3l. i got it from my grandfather this cars has 120k miles are was rarely driven since 2003. me & ma dad are trying to repair all the probs we come across. here is my prob. when my car idles it does run smooths it sounds like im stepping on the gas then off then on then off idk why. then when you press the brake to goto drive from park, its like the engine sounds like it wants to a stop then gets back to idle & at the same time this happens the car like jumps forward like some1 pushed my car from the back. my dad said the engines isnt knocking or anything. idk what the prob is. the previous took the car to the dealer for all repairs. i already changed the oil. the same spark plugs & wires n stuff is still there from when this was originally made. he sai he always put 93 gas in the car i recently poured 5 gallons of 83 in the tank 3 days ago to keep it runing. idk what the hell the prob is but if you need more info or wud like me to upload a video of it ill glady do so.
 

·
Registered
Joined
·
29 Posts
I once worked on a ranger and it had the similar symptoms you are talking about with the rpms going up and down. This was in my auto tech class and was finally discovered that the throttle position sensor was going up and down in voltage thus making the rpms go up and down. also you might check your idle air control valve, sometimes you can clean them with throttle body cleaner and they work just fine. The idle air control or iac valve controls your air intake at idle and sometimes get dirty with carbon buildup. you might also adjust your idle a little to help with the shifting jump. a good tune up is always good ( spark plugs, wires ect.)

Hope this helps. If it was my car this is where I would start.
 

·
Registered
Joined
·
38 Posts
Discussion Starter #3
Well the original spark plugs & wires are still on the car so i should do that first & if the problem wit the shifting jump, clean or replace idle air control valve & turn the idle up a notch or 2 right. quick question how do i turn up the idle?
 

·
Registered
Joined
·
3,900 Posts
The set screw on top of the throttle body.

That is not an idle screw its called a minimum idle setting screw. All electronic engines idle from the IAC not the screw. It sounds like you have a BAD TPS sensor. Replace it and do a minimum idle setting and adjust the TPS to .95-.98 VOLTS. Hope this helps Peace Tom
 

·
Registered
Joined
·
29 Posts
ya like i said before, check out your throttle position sensor, then set your minimum idle. i set mine to about 700-800 rpms when put in park.
 

·
Registered
Joined
·
3,900 Posts
ya like i said before, check out your throttle position sensor, then set your minimum idle. i set mine to about 700-800 rpms when put in park.

TOTALLY CORRECT
:bigthumbsup:goodpost:thanks:


Disconnect the IAC set the min idle to 700-750 install the IAC plug back then set the TPS to .95-.98 Good to go after this adjustment
 
1 - 7 of 7 Posts
Status
Not open for further replies.
Top