Ford Mustang Forum banner

engine light

1070 Views 6 Replies 5 Participants Last post by  crazyjj
i was ganna take my car to dealer for airbag light . i have predeator so i download the original back up everything was looking good but all the sudden now engine light is on but car is running fine
1 - 7 of 7 Posts
And everything is stock (intake, etc.)?
Use your Predator to find out what the error code is.
crazyjj said:
i was ganna take my car to dealer for airbag light . i have predeator so i download the original back up everything was looking good but all the sudden now engine light is on but car is running fine
Try disconnecting the battery for 15 minutes. I had two lean codes and this corrected the engine light, never came back on. Atfer what you did the computer my just need to reset itself.
steeda install?

good Q..did you ijnstall a cai? cold air intake?I had engine light after steeda cai install...error code was running "lean bank one and two"..steeda told me ford changed something and the cai's had either a 9mm or 10 mm intake thrtaot, I measured it, sent it to steeda, ...they sent me a new calibrator downloaded the new program and heard the manifold adjust, engine light gone on start up...
I guess you ment 9 or 10 CM intake THROAT...???
when i was taking my car to the dealer i put the old settings back on for the comp cheap(diablosport) and i took the car and they said my air flow sensor is the problem and then they changed it and i got my car i still have the c&l intake in it anyway i was driving home the light came on again and after i got home i put the 93 octane back on and the light when off so im happy with it for the airback light i had a short of wire under the passenger seat they fixed that too i didnt pay nothing. thanks all u guys
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top