Ford Mustang Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
150 Posts
Discussion Starter #1
this is the third time its happened so i'm accepting that i have a problem. all three times are about a month separated tho? and i do a lot of driving. while i was driving on the parkway today my engine simply turned off. i pulled over to the side of the road and it wouldn't start. like you could hear the starter clicking but the engine wouldn't turn over. after like 10 tries it finally started. any ideas ?
 

·
Registered
Joined
·
1,532 Posts
Alternator could be on its way out. And be sure and check your battery connections for corrosion and firm connection.
 

·
Registered
Joined
·
150 Posts
Discussion Starter #3
yeah really wish i had a volt gauge right now hahaha. but yeah im getting them both tested at autozone tmrw. if not that any other suggestions ? cause once it started everything like lights and stuff worked fine
 

·
Registered
Joined
·
150 Posts
Discussion Starter #5
ehh new head unit and two new speakers in the back. nothing fancy. i do run a gps and cop scanner at all times tho. could that be too much ?
 

·
Registered
Joined
·
150 Posts
Discussion Starter #6
ok just got my entire system checked by a mechanic. came up nothing and he has no idea what it could be.....
 

·
Registered
Joined
·
777 Posts
ehh new head unit and two new speakers in the back. nothing fancy. i do run a gps and cop scanner at all times tho. could that be too much ?
This could be your problem. I have heard lots of issues with aftermarket head units and power issues with these cars.
 

·
Registered
Joined
·
549 Posts
one thing to try is cleaning your throttle body. mine was doing that, so i checked the tb out, it was dirty as can be. i cleaned it, haven't had an issue since.
 
1 - 8 of 8 Posts
Top