Ford Mustang Forum banner

Status
Not open for further replies.
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
hello fellow mustang lovers.i have a totally baffling question.sometimes after ive driven my car or even when its cold,and its a fuel injected 86 g.t,it will rev to around 2500 rpm for about 5 seconds then rev down.ive cleaned the throttle body,ran injector cleaner through it,changed the fuel pump and filter,cleaned the air bypass solenoid and changed the air filter.im stumped.any suggestions you good people might have will be greatly appreciated.thank you and talk to you all soon.im new to this site so bear with me if im not up to date on it.thanks.:eyebulge:
 

·
Registered
Joined
·
455 Posts
I have had that same problem before just mine didn't rev as high as that. The problem with mine that I tracked down and fixed was the EGR valve. Another thing I would check is for vacuum leaks. Hope this helps.
 

·
Registered
Joined
·
13 Posts
My brother had a problem like that on his truck and we changed the mass air flow sensor that fixed for a while then the cam postioning sensor craped out i dont know if this will help you but i thought i would tell you
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
erratic ldle

well thank you very much to responding to my question.i did fix my egr valve and replaced 1 o2 sensor,but still nothing changed.also,ive replaced cap,rotor,plugs and wires plus starter solenoid and a new battery.besides these items excluding the fact that you mentioned vacuum leaks,is it possible i have another bad sensor,or even worse,the computer itself?if you have any thoughts on that it would be greatly appreciates.always keeping the 5.0 faith.
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top