Ford Mustang Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Hello all,

When I bought my Mustang, I wanted to install an aftermarket head unit in it and I got all of the equipment I needed based off the other thread I saw on here. The stock radio and CD player that came with the car when I bought it off a guy on CL stopped working, so I assumed that they had finally kicked the bucket. (The radio itself stopped working all together, just allowing the CD player to work which later eventually died.) When I pulled the radio I quickly realized why: the previous owner had completely destroyed the factory amp/radio harness when he installed what I assumed to be an aftermarket head unit. There were 'T' connectors that ran off the factory radio to a LOC which ran to the speakers. Since the factory harness has been chewed to bits by the last owner doing a few radio installs, I know this is what is causing my radio to work intermittently. My issue now is that I can't find a replacement. Does anyone know what the part number is, or where I can find a replacement for the factory harness? When I search google it only shows up with aftermarket head unit harnesses.

Much thanks!
 

·
Registered
Joined
·
117 Posts
Probably your best bet is a salvage yard or one of the guys that parts out Mustangs on Craigslist.

But, you can check with Late Model Restoration, Ron Francis, and Painless. They have all or parts of the wiring harnesses depending on the year. But, used will be much cheaper.
 
1 - 4 of 4 Posts
Top