Ford Mustang Forum banner

Status
Not open for further replies.
1 - 9 of 9 Posts

·
Registered
Joined
·
359 Posts
Discussion Starter #1
ok so i have a bad surging idle so i pulled some codes here you go

66 - , MAF signal below minimum test voltage of .4vdc (O,M,R), Temperature Circuit Grounded (M,O)

21 - Engine Coolant Temperature, ECT Sensor Out Of Self Test Range. 0.3 volts (250°F) to 3.7 volts (50°F)(O,R)

18 - Spark Out (SPOUT) Circuit Open (R), Loss Of Ignition Diagnostic Module Input To PCM/SPOUT Circuit Grounded (M)

13 - RPM Not Within Self Test Lower Limit (R), DC Motor Did Not Move (O,M,R), Idle Speed Control motor or Air Bypass not controlling idle properly -generally idle too high

44 - Secondary Air System Inoperative. bank one, passenger side (R)

94 - Secondary Air Injection Inoperative. bank two, driver side (R), Torque Converter Clutch Solenoid Circuit Failure (O)




thanks in advance guys
 

·
Registered
Joined
·
319 Posts
Was this KOEO or KEOR?

Sounds like some bad sensors. Bad/dirty MAF will mess alot of things up. ECT doesn't help things (was it cold outside when you ran this?). Also check to make sure the plug that hooks to the bottom of the distributer is hooked up with a good connection, and the jumper is hooked up to the little plug near it as well (IIRC). IAC controls idle, thats pretty important if your having idle issues. Id suggest cleaning it at least. Air Injection nonesense can pop up if emmisions control equipment is not hooked up IIRC.

For most of the connections you check it might not be a bad idea to hit it with some electrical contact cleaner and dielectric grease.
 

·
Registered
Joined
·
359 Posts
Discussion Starter #3
the first code (66) was engine off

the rest were engine running
 

·
Registered
Joined
·
13,166 Posts
I think I would replace the MAF. Make sure your spout conn is plugged in and no broken/burnt wires. The ECT was probably not to temp when you ran these. The rest may go away if its the MAF. You could go to Autojunk and get a new ecm plug it in and see if it fixes things if not take it back (ooops did I say that, oh well wish they would go outta business anyway)
 

·
Registered
Joined
·
359 Posts
Discussion Starter #5
tomarrow i think im guna put the stock maf and injectors in
 

·
Registered
Joined
·
359 Posts
Discussion Starter #7
FIXED IT

c and l mass air meters suck


i put the stock 19# injectors and maf

runs way better and idles down to 600 with no surge even on start!




who wants to buy a c and l maf?
 

·
Registered
Joined
·
303 Posts
theres nothing wrong with c&l maf's unless you were using the wrong sample tube, they work the same as the stock except instead of needing a tune everytime you change injector sizes you just replace the sample tube. I've had one for over a year and running better than the stocker ever was.
 

·
Registered
Joined
·
6,328 Posts
the c&l meter is supposed to use the stock electronics..
 
1 - 9 of 9 Posts
Status
Not open for further replies.
Top