Ford Mustang Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
Hello,

I just bought a 2004 mustang, 40th anniversary. V-6 3.9.
I've had it for a week, there is a really loud whining under the hood, but yesterday when I turned it made a very slight clicking sound, not like a clanking sound or grinding, but clicking. Here is what I have found wrong....the whining...turn signals don't work unless steering wheel is tilted up.

This car is spotless, I bought it from the original owner, who bought it brand new. It was kept in a garage it's whole life. there is plenty power steering fluid.

Can anyone tell me if they have had this problem.

Thank you!!!!
 

·
Registered
Joined
·
992 Posts
The power steering pumps on these cars are loud for some reason. There are many other things that it could be, like an idler pulley, water pump, air conditioner compressor clutch bearing or several other things. You are going to have to try and isolate the noise somehow to figure out where it is coming from.

Turn signal problem is probably a broken or loose wire in the steering column.
 

·
Registered
Joined
·
6,124 Posts
I would drain out all of the factory power steering fluid and replace it with BG. The BG is going to be a little more expensive than the other stuff that you find. About $8 for 6 oz. Go ahead and change the serpentine belt while you are under there. You don't have to run 100% BG but I did. But I would do a fluid change anyway since the car is 11 years old.
 

·
Registered
Joined
·
18 Posts
Discussion Starter #4
Thank you for your responses, can u give me an idea on how to flush it without messing anything up?
 
1 - 4 of 4 Posts
Top