Ford Mustang Forum banner

Status
Not open for further replies.
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
My 1964 convertible acts like it is running out of gas, but I drained the tank and have about 6 to 8 gallons of gas in tank. The pick-up looks in good condition. In the process of checking fuel filter and pump. Any other suggestions as to what might be the problem. Thanks.
 

·
Registered
Joined
·
682 Posts
Rust plugging up the filter? How new are the tank/lines/filters? These things ARE 40 years old; that's the first things I'd look at/replace. Next on my list would be a faulty pump and maybe a carb rebuild, but that's going a bit far for a first guess. A lot more info (eg. when it does this, and how it acted before, and car info) would be a great help.
HTH
PS: There were no '64s; and technically no 64.5s if you asked Ford....is this a 64.5?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Yes, this is a 64.5. The car was running fine, then it just quit. No sputter or anything, just died and would not start again. Happened once before, but I thought I was out of gas and put gas in and it took right off. So didn't think much of it. The tank looks clean and I just replaced filter and rubber parts of gas line.
 

·
Registered
Joined
·
51 Posts
Sounds like you might want to take a look at the carb. I had mine freeze up on me up in the mountians, it could be as simple as a stuck float as well.
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top