Ford Mustang Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
76 Posts
Discussion Starter #1
Well, I sold my '04 GT a few months ago and have been miserable since!!! All my buddies have "toys" and I got nothing. Even my wife has a CBR 600 F4i!!!! I started looking and found a '03 Cobra for sale. I'd like a little advice on what to expect, look for, and mods.

The car looks good with good body lines. It has 71,000 miles on it. I'm getting it for high 14's. Pretty good price from what I could find. As far as mods go, he says it has a catted X pipe with some kind of mufflers and a pulley swap. Not sure what size pulley.

First off, is this a pretty good deal? What are some thing to look for on it once I get it home? What immediate maintenance would you perform? I don't know anything about supercharged cars. Thanks in advance, Todd
 

·
Banned
Joined
·
12,436 Posts
we have hashed this out many times, do a search in this forum...the main thing to look out for is the "head tick" issue, ask the owner if the recall was performed and have a service record history pulled on it at a Ford dealership...that and a carfax will tell you if the car was maintained.
 

·
Registered
Joined
·
5,089 Posts
+1 on head tick and just look for obvious things. See how it drives and go WOT to make sure the temp doesn't go high. AC works, no oil leaks, no clunks from rear end. When you get home, if you buy it, i would atleast change the oil, SC oil, tranny fluid. If coolant has never been changed, i would change that and the coolant for the intercooler. Plug swap too.
 

·
Registered
Joined
·
76 Posts
Discussion Starter #4
Thanks for info...got it home and seemed to run good. The CEL light came on and it stuttered a little. The code came back as an EGR code. Found a valve with 2 vacuum inlets. Neither one was hooked up. I found one line off and reattached it. We'll see. The other thing I noticed is the car falls flat when you step on it then sudenly the SC kicks in. Any idea why the hesitation? Thanks, Todd
 

·
Registered
Joined
·
806 Posts
Thanks for info...got it home and seemed to run good. The CEL light came on and it stuttered a little. The code came back as an EGR code. Found a valve with 2 vacuum inlets. Neither one was hooked up. I found one line off and reattached it. We'll see. The other thing I noticed is the car falls flat when you step on it then sudenly the SC kicks in. Any idea why the hesitation? Thanks, Todd
i wouldnt buy it.............
 

·
Registered
Joined
·
5,089 Posts
did you take it home and is bought it?
Sounds like it already has issues with it. Does it have a pulley swap already? Belt could be slipping and then catching. check for black dust on the pulley or idlers close to it. What does the boost gauge do when that happens? Or...does the rpms shoot up real fast and then grab? That could be a clutch problem.
I know it's awesome to get one but def don't buy some elses problem car just to have a Terminator.
 

·
Registered
Joined
·
76 Posts
Discussion Starter #7
I understand what you are saying. The clutch grabs fine. I think its a tuning issue. Everything I've read says that the car will require a tune when the pulley is swapped. The car seems solid I fixed the EGR issue. The seller cleaned the engine then coated it with Armor-all. As a result when the engine heated up the Armor-all seaped in and the EGR vacuum hose slid off. Other that that, no ticks or anny noises. Only thing I'm not real happy with is some silly cosmetics. It has a broken vent in dash and a couple chips and scratches in paint. Gonna get ahold of a tuner tomorrow.. Thanks again, Todd
 

·
Registered
Joined
·
901 Posts
Good luck with the ride! $14xxx for a 71k mileage Terminator is a good deal, assuming it has no problems. Mine had about 67,000 miles on it and I sold it for a LOT more then that!
 

·
Registered
Joined
·
76 Posts
Discussion Starter #9
Thanks BigTuna....I feel I got a good deal. Just gotta sort out a few bugs. Todd
 
1 - 9 of 9 Posts
Top