Ford Mustang Forum banner

Status
Not open for further replies.
1 - 6 of 6 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter #1
Ok, I am new here, just got a 95 GT with the 5.0 with the 5 speed. It is hard to start when its warm, having to pump it once and then when it starts it revs high for about 30 seconds. If I dont pump it, the motor just turns over like no fuel is present. So needless to say I am assuming its fuel related.

About the car, its a bone stock 95 GT, 5.0, with the five speed. It has a no name "K&N" like air filter the seller called it a cold air induction. It has an aftermarket coil, Blaster 2 I think, but that is where the mods end. Assume everything else is stock, and the person didnt appear to be keen on keeping up on maintance so I cant verify the fuel filter status etc.....

Please help.....
 

·
Registered
Joined
·
136 Posts
Since the maintenance of the car is unknown a full tune-up would probably be a great place to start. I know I was suprised by what it did with mine when i bought my car.
 

·
Registered
Joined
·
33 Posts
Discussion Starter #3
Will do. What wires do you recommend? I usually run Taylors but I am thinking about switching. I like the FMS products, are they any good?
 

·
Registered
Joined
·
4,806 Posts
I'm running FMS 9mm wires and they work excellent. Had them for about 2 1/2 years now.
 

·
Registered
Joined
·
19 Posts
I have a 93 5.0 Mustang and they came with fairly new NGK Plugs but had AC Delco wires. I changed those over to a set of blue Ford Racing 9mm wires.
 

·
Registered
Joined
·
33 Posts
Discussion Starter #6
I like the FMS look too. I am not young and my hanging chrome off the motor and undercarriage are over. The sleeper "factory" rippers are always in style like the corbras, where they look like they are faster then hell and meant that way from the factory. I think the FMS products give the stangs that look, also they are competive in prices.

What kind of coils you guys running?
 
1 - 6 of 6 Posts
Status
Not open for further replies.
Top