Ford Mustang Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
82 Posts
Discussion Starter · #1 ·
The first time it came on the dealer said it was a sensor for Fuel vapor that caused it to come on. I did get the tank replaced too cause I had the Fillup problem. The engine light came back on a week later. I take it back in on Wed. Has anyone else had this happen? I just wonder if the new tank and this fuel vapor sensor has something to do with it. I guess i'll find out on thursday

05 satin silver GT,5-speed manual
Charcoal/red leather, Bullit wheels,etc.

67 mustang Dark Moss Green, 289 auto.
67 linconl 4-door Vert
55Olds
62 Studebaker Lark
And a 70
Buick
 

·
Registered
Joined
·
914 Posts
I had mine come on and it turned out to be a fuel sending unit - I am still on my original gas tank, but had to have the sending unit replaced. The gas tank would suddenly read empty and then go back to full (or where ever it should have been) when I would restart the car. It did this a couple of times and then the engine light stayed on. That's when I took it in and waited 2 days for them to replace the unit and then not even put the carpet in my trunk back in.
FWIW
 

·
Registered
Joined
·
1 Posts
Check Engine Light

Mine Light came on three days after the rearend was replaced. It ended up they replaced the evaporative emission canister purge valve, and fuel filler cap. The car is a january 05 build date, so far no gas fill problems as others have had. Picked the car up on a friday had 90 miles on it (never titled) drove it for four hours and the rearend was howling when you let off the gas, took it back Saturday morning 3/4's of quart low on fluid! The dealer filled and said drive it awhile the noise should go away, I took it back a week later and they ordered a new rear and replaced it. Took about a week to come in. Dealer has been great so far on service just to bad its spending more time there then on the road. Now have 670 miles on car which I bought on june 3rd.
 
1 - 3 of 3 Posts
Top