Ford Mustang Forum banner

Status
Not open for further replies.
1 - 8 of 8 Posts

·
Registered
Joined
·
2,096 Posts
Discussion Starter · #1 ·
Hey, ever since i got my 373s, i have tried a few things and i still get the same result, i spin out in 1st and 2nd gear. the latest thing i tried is just letting go at 1000rpm and it gripps good at the begingin but breaks loose at like 4500. and when i shift into 2nd it keeps on spinning. Last night i raced my buddies V6 with 373s for fun, and i swear he had me by a head light 1st and 2nd gear cuz i was spinning out so bad. I was really good a launching with stock gears, but i need to practice some more because i wanna go to track before they close it down for a few weeks. Anyhow anyone have any suggestions. i used to drop it at 2500rpm and spun a bit but not that much. now i do that and ill shread my tires.

Let me know.
P.S. my 1st gears roll pulls are sick =)
 

·
Registered
Joined
·
18 Posts
I would try slipping the clutch when you take off, dropp your tire pressure or get some drag radials. 3.73 gears with street tires will spin real easy. I have 3.73's in my car with drag radials it spins alittle but not like with street tries do
 

·
Registered
Joined
·
2,579 Posts
1. If you still have the stock traction lock, it may have started to go south and now you've got the one wheel peel ordeal.

2. Since you are loosing traction high in the rpm band, you may have just overpowered your tires gripping ability. I don't know what kind of wheel and tire package you have so I'm not sure on what to advise you to do other than get stickier tires.

If I had to guess, I'd say #1 is most likely your problem.
 

·
Registered
Joined
·
2,096 Posts
Discussion Starter · #4 ·
I do have stock trac loc, but i did squeel them a bit ago and it did spin both, and i am running Sumitomo HTRZ IIs they arent the best but are not worse, with stock wheels.
 

·
Registered
Joined
·
364 Posts
I think it's your tires. I don't have that problem with my 3.90s and your car and mine have similar mods except for the x-pipe. I've got to launch easy in 1st, but then I can bang-shift it into 2nd and 3rd and not get more than a short squeal of rubber. I'm running Continental ContiExtremeContacts in the stock size.
 

·
Registered
Joined
·
2,096 Posts
Discussion Starter · #6 ·
i have driven these tires for about 5 minutes and when i touch them they are pretty tacky in reguards to stickyness. i just think i also need more prac taking off with the gears. maybe feathering the cluth at like 2000
anyhow any other tips can be welcomed.
 

·
Registered
Joined
·
8 Posts
Carguy where in florida are you located? I race at Bradenton Motor Sports Park in Bradenton Fl. I have a 99 gt 5 speed i put a set of 245/45/17 nitto drag radials on today and let me tell you they hook great,im having 373 gears installed next week.
 

·
Registered
Joined
·
2,096 Posts
Discussion Starter · #8 ·
i live in bradenton Florida, like 6 miles away from the track. where do you live, hit me up on a pm.. later
 
1 - 8 of 8 Posts
Status
Not open for further replies.
Top