Ford Mustang Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
372 Posts
Discussion Starter #1
my 86 seems to be having trouble getting over 100. i have 373's and it pulls hard up about 70 or 80 then its like it has nothing left that and it seems like my drive shaft vibrates a decent amount any suggestions?
 

·
Registered
Joined
·
1,652 Posts
For the driveshaft vibrations check your u joints.

As for the not pulling make sure you have all the basic things covered like fuel filter, tune up, etc.

Did the car ever pull hard over 80? How many miles are on it? You could try a compression test and leak down test to see if the engine is just getting tired.
 

·
Registered
Joined
·
7 Posts
hey give me a little more info about your car and mods.
maybe i can help you more.
factory fuel and ignition system?
are you able to monitor your fuel pressure while this is hapening? also might be wise to invest in a wideband o2
Is the engine losing power after 80 or is the vibration just too much to continue acceloration?
pull your plugs and inspect them.
good luck
 

·
Registered
Joined
·
372 Posts
Discussion Starter #4
it seems like it was always the vibration. its a 306 with a mild cam other then that the motors all stock and im sure a stock 50 would be able to at least hit that the motor is almost brand new the block has about 2k miles on it since it was totally rebuilt so im sure the vibration has something to do with it because i dont want to keep pushing it and break something ya know
 

·
Registered
Joined
·
1,016 Posts
it seems like it was always the vibration. its a 306 with a mild cam other then that the motors all stock and im sure a stock 50 would be able to at least hit that the motor is almost brand new the block has about 2k miles on it since it was totally rebuilt so im sure the vibration has something to do with it because i dont want to keep pushing it and break something ya know
Shouldnt be pulling a brand new motor over 100 :nono: Check compression and get back to us.
 

·
Registered
Joined
·
372 Posts
Discussion Starter #6
well its not brand new its like 8 years old hahah i just dont put alot of miles on it
 
1 - 6 of 6 Posts
Top