Ford Mustang Forum banner

Status
Not open for further replies.
1 - 5 of 5 Posts

·
Registered
Joined
·
31 Posts
Discussion Starter #1
My car is not running right, it started about a month ago out of no where, it has a screwed up idle, (it bounces back n forth between 800 n 1100 rpm), it has a hiccup at steady throttle, almost like i let the throttle on and off, its mainly at part throttle it doesnt seem to do it at WOT,and with the mass air computer in when i start it for the first time in the day it revs to 2000 rpm then dies. I did the mass air conversion on an 87. It ran good for a month or two after i did it. I put the speed density system back in to see if it was a problem with the mass air but theres no change. Also it lost some power, it has new plugs, wires, cap, rotor, ignition module, tps, and it doesnt appear to have a vacuum leak. Any ideas what it could be?
 

·
Registered
Joined
·
56 Posts
After the codes...

try retarding the timing about 2 degrees. Sounds nuts just got my neighbors to stop doing the same thing by retarding the timing.

But oull the codes like 89coupe said first. Could just be a bad sensor. When is the last time you took off your IAC and cleaned it. IAC affects Idle.
 

·
Registered
Joined
·
31 Posts
Discussion Starter #4
im gonna try to work on it this week and retard the timing, ive never cleaned the iac so im gonna try that too. my check engine light isnt on, will it still give trouble codes?
 

·
Registered
Joined
·
5,170 Posts
im gonna try to work on it this week and retard the timing, ive never cleaned the iac so im gonna try that too. my check engine light isnt on, will it still give trouble codes?

Yes it can still have codes. Not all OBD-1 codes will flash a CEL
 
1 - 5 of 5 Posts
Status
Not open for further replies.
Top