Ford Mustang Forum banner
Status
Not open for further replies.
1 - 8 of 8 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
Hello,I have a 1966 mustang with a 1989 5.0 mustang engine and 5 speed trans installed in the car.I have some questions?.I have rebuilt the bottom end stock with the trick flow twisted wedge kit,BBK intake+filter,70mm throttle body,MSD Distributor,MSD 6al box,MSD coil,19lbs injectors and stock sensors,ERG block off plate,9al computer(eec).I am haveing problems the motor it will idle when cold but when warms up it hunt's for an idle,Also sometimes when you snap the trottle it will pop back threw the air filter and when accelerating it's like the motor is flat no real power backfires a little almost like the rev limiter is on.The timming is set at 12 degres btdc.any ideas.Thank you.Steve
 

·
Registered
Joined
·
621 Posts
Are you getting any engine codes? It could be multiple problems.

I had idle hunting in mine and the problem was a bad connecton in a plug to the oxygen sensors. There are several things that can cause a hunting idle. It also sounds like it might be rich or lean. That means injector flow is wrong, and that could be caused by anything from fuel pressure to sensors.

The A9L tries to learn from the HEGO sensors what the mixture is. It tries to apply a correction that it learns over time. It sounds like something is quite a bit off, so you proably need to look at fuel pressure and codes.

The correct TPS voltage at idle is about .6 volts to perhaps 1.2 volts. Anything in that range will work. Do NOT worry about getting it to x.xxx volts. The computer doesn't care. If it is around .7 to 1.1 volts, it will be perfectly fine.

Tom
 

·
Registered
Joined
·
46,010 Posts
I would go over the timing and ignition system, when there's backfiring and a lack of power it's usually in the timing/ignition system.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #6 ·
well I changed the distributor,map sensor,maf sensor,modual on the distributor,computer the only thing left is th MSD 6al box and MSD coil.Does anyone think it could be the 6al box.If so can I run without it.and how?
 
1 - 8 of 8 Posts
Status
Not open for further replies.
Top