Ford Mustang Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hello All, new to the forum here, but I'm having a terrible time with my newly ordered Bama 4 bank eliminator chip...

Here's an attempted short version: Stang running fine, no issues, just wanted a little more HP. First time dealing with tuner chips, ordered Bama 4 bank eliminator. They sent me a chip with no tunes the first time (after I had installed on the car and it caused fuel pump to constantly run and car wont stay running they said they'd re-tune and send back). Tried running the car after un-installing chip - car wont run with same symptoms as if the chip was still installed and running eye-watering rich (un-hooked battery overnight - no fix). Re-attempted start with a new MAF b/c the previous owner had left the stock one on. New MAF is calibrated for my 24lb injectors. Bama also knows about my MAF including all my other MODS. Got chip back from Bama with supposed tunes, fuel pump issue fixed (still running rich), however car will only stay running after giving some gas; will idle around 450 RPM, work its way up to 1000 RPM for about a minute, idle surge violently and stall. Checked TPS (.94 volts w/ ignition on). Started throwing codes as well; KOEO I got 15, 85, 96. KOER were harder to get b/c of the car running so rich and burning my eyes, but I think I got 96 and 66. I'm using the manual jumper method.

I'm getting to my wits end with Bama, and contimplating on getting another ECU, but dont want to screw that one up again if its the chip. (I'm in Hawaii so its over a month wait to order an ECU), Amazon doesn't have my model.

I appreciate any assistance with this, Thanks!
 

·
Registered
Joined
·
2,057 Posts
Hello All, new to the forum here, but I'm having a terrible time with my newly ordered Bama 4 bank eliminator chip...

Here's an attempted short version: Stang running fine, no issues, just wanted a little more HP. First time dealing with tuner chips, ordered Bama 4 bank eliminator. They sent me a chip with no tunes the first time (after I had installed on the car and it caused fuel pump to constantly run and car wont stay running they said they'd re-tune and send back). Tried running the car after un-installing chip - car wont run with same symptoms as if the chip was still installed and running eye-watering rich (un-hooked battery overnight - no fix). Re-attempted start with a new MAF b/c the previous owner had left the stock one on. New MAF is calibrated for my 24lb injectors. Bama also knows about my MAF including all my other MODS. Got chip back from Bama with supposed tunes, fuel pump issue fixed (still running rich), however car will only stay running after giving some gas; will idle around 450 RPM, work its way up to 1000 RPM for about a minute, idle surge violently and stall. Checked TPS (.94 volts w/ ignition on). Started throwing codes as well; KOEO I got 15, 85, 96. KOER were harder to get b/c of the car running so rich and burning my eyes, but I think I got 96 and 66. I'm using the manual jumper method.

I'm getting to my wits end with Bama, and contimplating on getting another ECU, but dont want to screw that one up again if its the chip. (I'm in Hawaii so its over a month wait to order an ECU), Amazon doesn't have my model.

I appreciate any assistance with this, Thanks!

Personally the amount of increase in power in relation
to cost of a Bama chip isn't worth it to me. The stock
ECU does a pretty good job of engine management and
adapts well to modifications. There is always the possibility
of problems that come with installing a chip as you well know.
If your car runs good without the chip. Contact the company
and request a refund and spend your money elsewhere.
 

·
Registered
1991 Ford Mustang LX
Joined
·
2,222 Posts
Code 15 is present because of the chip.
Code 66 is related to the maf sensor.Since your maf sensor is new,you might wanna check the wiring for any issues,but it wouldn't hurt to test the maf sensor anyways.
Code 96 is related to the fuel pump relay & the fp monitor signal wire,pin #19 at the ecm.

The 1st link below details testing procedures for all of the fuel pump related codes(i.e.-87/95/96)
Another thing you should do is remove the ecm ***after youve done all the tests youre gonna do on the ecm & its wiring because any codes present now will be gone once you disconnect the battery***
from the kick panel,remove the rear cover & inspect all 3 blueish/green capacitors on the board for any damage.They'll show signs of leakage,buldging or broken/eroded posts,if theyre defective.Issues with these capacitors can cause some of the symptoms youre having and it only takes a few minutes to remove the cover and inspect the board.
You did make sure to reconnect the ecm ground to the floorboard before you reinstalled it didnt you??
Just checking because some guys forget.

The 2nd link details test procedures for the maf sensor,to make sure the sensor & its wiring are ok.The sensor might be fine,but there could be a wire fault somewhere.



Fuel Pump Codes 87/95/96 Troubleshooting


http://easyautodiagnostics.com/ford/4.9L-5.0L-5.8L/maf-sensor-tests-1
 

·
Registered
Joined
·
430 Posts
Do yourself a favor.... If you have the bama 4 bank chip it has to be tuned by a tuner that knows what he/she is doing if you want your engine to work properly. Ask me how I know.

I had to borrow my buddys moates tuned chip to get my fox from Nova Scotia down to New Hampshire to have tuned.

The guy that tuned mine laughed when I told him my car would'nt run right with the bama 4 bank chip. He told me Bama was in the SELLING business, not the TUNING business...BIG difference as he mentioned I would soon see. He was right

The guy that tuned mine is also a distributor for the bama 4 bank chip. After I bought the chip from the vendor he informed me that I could have bought the chip from him for $100.00 cheaper...go figure! :surprise:
 

·
Registered
Joined
·
1,646 Posts
Do yourself a favor.... If you have the bama 4 bank chip it has to be tuned by a tuner that knows what he/she is doing if you want your engine to work properly. Ask me how I know.

I had to borrow my buddys moates tuned chip to get my fox from Nova Scotia down to New Hampshire to have tuned.

The guy that tuned mine laughed when I told him my car would'nt run right with the bama 4 bank chip. He told me Bama was in the SELLING business, not the TUNING business...BIG difference as he mentioned I would soon see. He was right

The guy that tuned mine is also a distributor for the bama 4 bank chip. After I bought the chip from the vendor he informed me that I could have bought the chip from him for $100.00 cheaper...go figure! :surprise:
Was this in Hudson New Hampshire?
 
1 - 7 of 7 Posts
Top