Ford Mustang Forum banner
Status
Not open for further replies.
1 - 4 of 4 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter · #1 ·
I am starting to lose it with this car. Its an 1989 gt auto that we have install the Trick Flow track heat kit to, along with a .030 over bore (pistons are trw 8kl2482f30), it also has bbk shortie headers and 2.5 flowmasters system (no cats), 36 lb injectors and calabrated maf, 70mm tb and a paxton sn92 superchager running about 5 pis and 255 lph in tank pump and an aeromotive adjustable fuel regulator. The problem that i'm having is setting it up. When i first did it (its my wife's car and she got the bits together(i'm a chevy man myself) i put in the plugs she got, ur45ix these being a .460 reach, it seemed to run good on them but i was told that Iridium plugs were not a good thing with a blowen motor. I then find out when looking for new plugs, that these heads should have .750 reach plug, now begin the problems. I got some bkr6e, these bring the right reach, now with the timing at 10 degrees it pinged so i got a colder plug by one step it still pinged i reset the cam to trick flows recomendation of 4 degrees advanced still it pinged, i upped the fuel pressure to 50psi still it pinged, so i set the timing to where it would no long ping, well i got down as far as 2 deg still it pinged, but not to bad and it would only ping at low revs it seemed. i have now put in the shorter reach plugs(the irradium) and it has all most stopped pinging at 10 deg. can anyone help with this before i take a gallon to it and light it up.
Thanx Dave.
 

·
Registered
Joined
·
216 Posts
What CC are the heads? My initial thought is the compression is too high with the boost for the gas you are running.
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #3 ·
The heads are 61cc and we use 97-98 fuel. The static compression comes out at around 9.5.
 

·
Registered
Joined
·
45,742 Posts
There's a LOT of things that can cause pinging like that. The compression of 9.5:1 isn't bad, and the octane is more than enough. You're only running 5 psi too. I would say use the Iridium plugs if they work the best, every engine is different and it'll let you know if it doesn't like something.
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top