Ford Mustang Forum banner

Status
Not open for further replies.
1 - 8 of 8 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
Alright guys i have another post and everyone tells me to get a tune and it would solve my problems. Now my question is how come everytime i try to load the strategy tune......i get that d*** wrench light and its giving me a p060c code on my scanner?
 

·
Registered
Joined
·
13,191 Posts
It's some type of programming error. Did you get any tunes with it?
P060C ICM Main Processor Performance
 

·
Registered
Joined
·
11,864 Posts
as suggested earlier, did the dealer check your fuel pressure? fuel pumps will cause trouble. it could be as simple as darladoom suggested by changing your filter. how many miles on your car? have you changed the fuel filter?($14.00) ive never had a strategy tune ( one size fits all) but others have had problems with them from buying a tuner from am. so just to set things straight, your car ran perfect till you got the exaust done? and the dealer checked it out after the exaust also?? i cant believe they couldnt find the problem.:scratchchin

( on a side note, this is a good example on how it doesnt pay to get the bbk or kn cai cause you have the 2-250.00 or so. cause then you gonna need the tuner for 400, then in the end your gonna pay 120 more for custom tunes adding up to 7-800.00 when you could get the jlt( top performance cai),tuner and custom tunes writen just for your car, combo for about 500.00) just my opinion :so
 

·
Registered
Joined
·
13 Posts
Discussion Starter #4
Yeah i paid the dealer 250 dollars so far with nothing accomplished......I got 96540 miles on it yeah i know its alot guys but i drive 102 miles a day its all highway miles. The two things ive noticed is the vaccume gauge says late ignition timing. its reading 12-15 in.hg and anther thing when i run my car and the idle is low.......if i slam the gas down in neutral. My car is acting like its either getting to much fuel or starving for fuel. Sometimes it just shuts the engine off, other times it just bogs down and struggles to stay running with the rpm jumping from 100 to 500 but managing to stay running.......the dealer ran an electronic scanner to get my fuel pressure he says it was at 70 psi but when i run my own obd2 scanner its at about 39 psi.......i got new plugs, wires, fuel injectors, fuel filter, cam postition sensor. The only two codes i get before i do the tune is p0340 and p0106 and the check engine light is on after the tune its p0340, p0106 and p060c and the check engine light is on and the wrench light.......
 

·
Registered
Joined
·
13,191 Posts
As I stated previously, the code p060c is ICM Main Processor Performance. Which means you may have a bad ICM or a problem with the connector. If this was giving you trouble before the tuner, a tune isn't going to help you.

You also don't need to put in multiple threads on the same subject.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #6
OK pcfrish if u dont understand what im saying then dont reply. If i had a problem with my internal control module. It wouldnt only come on after the flash......it would also be on before the flash..........
 

·
Registered
Joined
·
11,864 Posts
on the 06, fuel pressure should be 35-70( which is a pretty big variant). the fuel system hold pressure after 5 minutes should be less than 5 psi loss from the operating pressure. if they got 70, and you got 39. that might be a sign. maybe double check that the fuel filter fittings are clicked on good. you could remove the fuel pump, check the fuel pump inlet strainer for restrictions. we had to replace a fuel pump on our 06 at 28,000 miles, intermintant hesitation.
 
1 - 8 of 8 Posts
Status
Not open for further replies.
Top