Ford Mustang Forum banner

Status
Not open for further replies.
1 - 3 of 3 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter · #1 ·
Hey i need some BIG BIG BIG HELP... I'm puting in a new CD Player in my car... I removed the old one, tryed to put in the new one... Now my speedometer dosent work my power locks dont work... They will lock with the power botton inside but when i press the up or unlock botton it turns on the lights... The clock dosent work... The roof light dosent work... The power mirrors... So whats GOING ON???????????? The new cd player dosent even work... I tried putting the old stuff back in and it dosent work either... Please Let Me Know Something.................... Thanks A Bunch.......:mad: :mad:
 

·
Registered
Joined
·
91 Posts
Did you look at your fuse box? I know when i installed a cd player on my old explorer i had a fuse blow but it wasnt as bad as yours, i lost like my dome lights and wipers.If ya find it just run over to autozone and pick another up. If im not mistaken i believe the fuse box on mustangs will be located under your hood close to the driver side window corner. But not sure cause i havent ever looked for it. lol

Hope this helps
 

·
Registered
Joined
·
72 Posts
Nur_Stang said:
Did you look at your fuse box? I know when i installed a cd player on my old explorer i had a fuse blow but it wasnt as bad as yours, i lost like my dome lights and wipers.If ya find it just run over to autozone and pick another up. If im not mistaken i believe the fuse box on mustangs will be located under your hood close to the driver side window corner. But not sure cause i havent ever looked for it. lol

Hope this helps
On my 96, its right where you said it was. A black box labeled 'electrical'
 
1 - 3 of 3 Posts
Status
Not open for further replies.
Top