Ford Mustang Forum banner

Status
Not open for further replies.
1 - 18 of 18 Posts

·
Registered
Joined
·
119 Posts
Discussion Starter #1
So almost six months later, and alot of hair pulling and swearing.... the issue is solved! Te problem was..... drum roll please........ faulty IAC valve motor!!!! Woohoo!!! Was not properly responding, would fizzle off and on in the slightest degree throwing off the Air / fuel mixture ever so slightly and causing the shake and hesitation. Swapped it out and problem is GONE!!!! :myhappydance: Tore around the streets to celebrate and smoked a riced out Accord with confidence! ( and the kids in the car too, who had to be bribed with candy into not telling thier mother! ) :nogrinner

Thank you everyone for your help!!!!! :thanks:
 

·
Registered
Joined
·
5,633 Posts
IAC once again. One of those "...it might be the fuel filter, but ALWAYS check the IAC" cases.

Congrats, Matt.
 

·
Registered
Joined
·
6,161 Posts
yay im glad! i know this problem has been bothering u for a long time.. what made u figure it out?
 

·
Registered
Joined
·
119 Posts
Discussion Starter #5
Thanks everybody! Yes, it has been bothering me forever! I was ready to put this horse down!

I had previously cleaned the IAC valve twice before, and then ruled it out of the equation.... But after process of elimination, just kept coming back to it.

It was the only thing wrong with the car when I bought it... a case of bouncy idle and low idle on hard braking, which was solved with the first cleaning.... but not everything can be solved with brake clean so after all signs kept pointing back to it, just replaced it.

There really were no tests I could perform without checking voltages against a working IAC, so unfortunately it was just a really long and frustrating process for which I have not learned a sure fire method of helping others determine this as there problem.... but, as a team, we seem to be able to solve just about any problem... eventually :gringreen
 

·
Registered
Joined
·
2,867 Posts
glad you figured it out! :bigthumbsup
 

·
Registered
Joined
·
162 Posts
when i idol my RPMS like to randomly change from 500 to 1500 and back. do you think it could be a similar problem? i was told i need to clean my RGI valve but i have no idea what what is even after i google-ed it
 

·
Registered
Joined
·
140 Posts
when i idol my RPMS like to randomly change from 500 to 1500 and back. do you think it could be a similar problem? i was told i need to clean my RGI valve but i have no idea what what is even after i google-ed it
do you mean EGR valve? ive never heard of a RGI valve.... not saying its not out there but ive never heard of it as far as i remember
 

·
Registered
Joined
·
162 Posts
he said RGI. a friend of a friend ran codes on my mustang and after looking them up he said its eather the RGI valve or the O2 sensor. i asked him to run codes becuase of my shaddy idols and im averaging 15 mpg in my V6 (and i dont stand up on it at every opertuninty)
 

·
Registered
Joined
·
2,867 Posts
he said RGI. a friend of a friend ran codes on my mustang and after looking them up he said its eather the RGI valve or the O2 sensor. i asked him to run codes becuase of my shaddy idols and im averaging 15 mpg in my V6 (and i dont stand up on it at every opertuninty)
you misheard him, no such thing exists.

if you have a code dealing with exhaust, more than likely he said EGR valve.
 

·
Registered
Joined
·
138 Posts
Thanks everybody! Yes, it has been bothering me forever! I was ready to put this horse down!

I had previously cleaned the IAC valve twice before, and then ruled it out of the equation.... But after process of elimination, just kept coming back to it.

It was the only thing wrong with the car when I bought it... a case of bouncy idle and low idle on hard braking, which was solved with the first cleaning.... but not everything can be solved with brake clean so after all signs kept pointing back to it, just replaced it.

There really were no tests I could perform without checking voltages against a working IAC, so unfortunately it was just a really long and frustrating process for which I have not learned a sure fire method of helping others determine this as there problem.... but, as a team, we seem to be able to solve just about any problem... eventually :gringreen

Congrats on solving your issue!!

I hope I can solve mine soon, because I really have not found the time to do so :(


well... Godspeed!! and btw, nice job pwning dat accord!
 

·
Registered
Joined
·
32 Posts
hey guys i´m a newbie...

i´m from Guatemala, in a few moments i will introduce myself formally,

congrats MAt

i have the same problem at this time, yesterday i change 4 oxygen sensor, spark plug wires and change the spark plug..

it ran very goo yesterday, but today my Engine Light came up to my dashboard again ... damn!!!.. at noon i will connet the scanner to look for the problem..

maybe it is my IAC...
 

·
Registered
Joined
·
119 Posts
Discussion Starter #13
Congrats on solving your issue!!

I hope I can solve mine soon, because I really have not found the time to do so :(


well... Godspeed!! and btw, nice job pwning dat accord!

We are here to help you out once you get the time... and thank you! The Accord owner was not too happy especially with my kids waving at him out the rear window! :gringreen
 

·
Registered
Joined
·
1,196 Posts
lol i hope u have a big sign on ur rear window that says "ya, ur ricer just got smoked by a mustang, and YES its a v6 :bigthumbsup" i want to change out my rear view mirror glasses to read "objects in mirror are foreign junkers" :) but ya man good to hear i always start with the IAC myself took me about 3 yrs to figure out what my issue was on my first ford truck...
 

·
Registered
Joined
·
119 Posts
Discussion Starter #15
I saw a great replacement sticker for the side view mirrors that said "Objects in Mirror are losing!" Ordered em yesterday!
 

·
Registered
Joined
·
138 Posts
Revivin' an old thread just to tell you guys that all of a sudden my hesitation/shake issues on my baby are gone...

I don't know how or why, all I did was wash the engine bay/engine itself.

Next day the car hesitated even more.

the NEXT day, it was wonders. That was two months ago :)
 

·
Registered
Joined
·
119 Posts
Discussion Starter #17
I don't even have a random guess as to what happened there.... but HOORAY!!!!! :kooky:
 

·
Registered
Joined
·
138 Posts
I agree, no clue...

But its all punchy now :)

Been rippin' the streets and beating cocky ricers :)

Love my v6 :D
 
1 - 18 of 18 Posts
Status
Not open for further replies.
Top