Ford Mustang Forum banner

Status
Not open for further replies.
1 - 12 of 12 Posts

·
Registered
Joined
·
210 Posts
Discussion Starter #1
I need some assistance in diagnosing a hesitation / misfire issue I am experiencing. car is a 2007 mustang gt with jltII / xcal3 / flowmasters.

anyway, the emissions warning light came on the other day (blinking) which according to the manual references a misfire. i thought maybe i had some bad gas in the car, as i was low (2 gallons or so) so i filled it back up and drove it a few more days without incident.

i since took a 900 mile roundtrip to niagara falls and had numerous times where the car would hesitate, and sound different at highway speeds. the emissions code light came on only once out of the numerous times i felt the hesitation. it does not seem to be regular, or happen at any speed. i h ave felt it at low speeds and high speeds, but more at highway speeds.

any thoughts as to what i might be dealing with.

spark plugs (havent had a chance to pull any and look yet)
O2 sensor?
clogged fuel filter?
anything else i can check myself?

any help would be appreciated. :headscratch::happydance:
 

·
Registered
Joined
·
1,664 Posts
Check your spark plugs and their gap (.035), make sure all of the spark plug wires are connected properly and check your air filter. If everything checks out then pull out your tuner and make some adjustments.
 

·
Premium Member
Joined
·
72,882 Posts
Plugged fuel injector or bad coil. And plug gap for these cars is .040-.050 (generally .045).
 

·
Registered
Joined
·
210 Posts
Discussion Starter #4
i have had the car a little over 2 years and 28k miles. do injectors really foul up that quickly? car is still under warranty, so i guess i will just take it back to stock and send it on back to ford. is there anyway I can tell what injector might be the culprit on my own?

thanks for the assistance
 

·
Premium Member
Joined
·
72,882 Posts
i have had the car a little over 2 years and 28k miles. do injectors really foul up that quickly? car is still under warranty, so i guess i will just take it back to stock and send it on back to ford. is there anyway I can tell what injector might be the culprit on my own?

thanks for the assistance
Only if you had the specific DTC telling you what cylinder the misfire was occurring on.
 

·
Registered
Joined
·
810 Posts
My plugs are gapped at .028. I normally swap them when I plan on doing some normal cruising. I've been logging that last few days so I didn't pull the plugs and they fouled up pretty quick. The codes I got was p0172 and 175, rich in both banks. I pulled the plugs and they were black.
 

·
Premium Member
Joined
·
72,882 Posts
My plugs are gapped at .028. I normally swap them when I plan on doing some normal cruising. I've been logging that last few days so I didn't pull the plugs and they fouled up pretty quick. The codes I got was p0172 and 175, rich in both banks. I pulled the plugs and they were black.
Wow that's a serious tight gap. I would think they would foul real easy.
 

·
Registered
Joined
·
810 Posts
Thats part of the reason why I got a trailer. So they don't foul on the way to the track. At 24psi they blow out gapped at .32
 

·
Registered
Joined
·
210 Posts
Discussion Starter #10
well, found my problem. a loose connection of the elctrical connection clip on one of the coil packs.

was triple checking all of the connections before i gave up and called the dealer. was pushing on the clips and connections to make sure they were secure, *click* found one that wasnt. seems to have been my problem as the car is running fine now with the 93 tune and a :) poor gas mileage lol
 

·
Premium Member
Joined
·
72,882 Posts
well, found my problem. a loose connection of the elctrical connection clip on one of the coil packs.

was triple checking all of the connections before i gave up and called the dealer. was pushing on the clips and connections to make sure they were secure, *click* found one that wasnt. seems to have been my problem as the car is running fine now with the 93 tune and a :) poor gas mileage lol
Good catch... Gotta love the simple fixes!
 

·
Registered
Joined
·
210 Posts
Discussion Starter #12
yeah, i wish all car installs or fixes ended up that simple. lol
 
1 - 12 of 12 Posts
Status
Not open for further replies.
Top