Ford Mustang Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
I believe I have an electrical problem in my car it was starting just fine until i switched the spark plugs put in the new quadrant kit for the clutch and its in the firing order of 13726548 its a 5.0 ho anybody got any suggestions im open to just about anything right now im going out of my mind:kooky:
it wont crank i tried the battery someone told me it was the starter fuses relay electrical wiring i dont know what to try right aout now they mickey moused a lot on this car so im not sure what it could e i replaced the rear end with a cobra with 3.73 gears new shocks bushing i put in a blue top mariner battery i have alot of electronics in the car but i installed everything after the issue i have 2 amps 2 kickers all new speakers back and front tweeters and 5 tvs new fuses i was thinking it was because of the new clutch quadrant i installed but im not sure i replaced all the spark plugs and placed the wires as they were so i dont know what i did different or what could be wrong need help asap
 

·
Registered
Joined
·
567 Posts
The clutch switch is where I would start, if you don't get power through it to the starter solenoid, the starter won't crank.
 

·
Registered
Joined
·
95 Posts
I believe I have an electrical problem in my car it was starting just fine until i switched the spark plugs put in the new quadrant kit for the clutch and its in the firing order of 13726548 its a 5.0 ho anybody got any suggestions im open to just about anything right now im going out of my mind:kooky:
it wont crank i tried the battery someone told me it was the starter fuses relay electrical wiring i dont know what to try right aout now they mickey moused a lot on this car so im not sure what it could e i replaced the rear end with a cobra with 3.73 gears new shocks bushing i put in a blue top mariner battery i have alot of electronics in the car but i installed everything after the issue i have 2 amps 2 kickers all new speakers back and front tweeters and 5 tvs new fuses i was thinking it was because of the new clutch quadrant i installed but im not sure i replaced all the spark plugs and placed the wires as they were so i dont know what i did different or what could be wrong need help asap
Go to your starter solenoid on the drivers side near the shock tower and pull of the little wire on top the find a flat head screwdriver to jump that and the nut closet to the steering wheel together and see if it cranks. If it does then that means that your issues could be that the power is not getting sent to the solenoid from the ignition trace then your clutch switch or neutral safety switch.
 

·
Registered
Joined
·
412 Posts
Go to your starter solenoid on the drivers side near the shock tower and pull of the little wire on top the find a flat head screwdriver to jump that and the nut closet to the steering wheel together and see if it cranks. If it does then that means that your issues could be that the power is not getting sent to the solenoid from the ignition trace then your clutch switch or neutral safety switch.
Not saying anyone here is dumb, but make sure you have the car in nuetral if you try jump the selenoid. After your quadrant install you may not have gotten the clutch safety switch quite right. Recheck this. I hope you have upgraded your alt.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #5
yeah i will be upgrading the alternator soon and thanks i will be trying that in the next hour i will let everyone know how that goes i believe its the clutch safety switch someone told me i can just eliminate it if there is any reasn why i shouldnt also advise me not to do so i will post if it workd or not but petty sure you guys are right:bigthumbsup
 

·
Registered
Joined
·
412 Posts
I would only eliminate/bypass the switch long enough to determine if it is the problem. They are a cheap part to purchase. Not saying your dumb, but the risk doesn't outway the cost. I know you are probably like me and automatically depress the clutch pedal everytime you go to start the car. I just wouldn't do it. Good luck gettin her back on the road.:smoke:
 

·
Registered
Joined
·
412 Posts
$23 @ autozone $35 @ Advance Auto, go fiqure.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #8
wow aint that something so i'll be going to autozone hahahaha and yeah i will bypass it for now and some guy that owns like 5-6 mustangs told me i could do it i took his word not really smart just started getting into mustangs so having a little trouble understanding the concept in how they set everything up but thanks for your help and i need all the luck i can get
 

·
Registered
Joined
·
412 Posts
You'll find plenty of help here. Great bunch of men on here. Go to your profile when you get time and fill out your signature so that we can see if your car is all stock or the modifcations that you have. This will save time, cause the info will be right there for people to see without having to ask. It matters on alot of issues you may encounter.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #10
thanks i appreciate it and i definitely will fill everyhing out and thanks for the advice im just going to buy a new clutch safety switch today throwing it in there and seein what happens:bigthumbsup
 

·
Registered
Joined
·
15 Posts
Discussion Starter #11
ok i tried to bypass it and it didnt work crank or anything different can anybody post a picture of the neutral safety switch so i have a better ideaand to make sure im doing this to the right part i bought the haynes book on the 94 mustang and it says nothing about it and i tried to buy one and auto zone and advance parts had no idea what the part is or what it looks like i go all new relays and circuit breakers also fuses replace all and still no luck:nono:
 
1 - 12 of 12 Posts
Top