Ford Mustang Forum banner
Status
Not open for further replies.
1 - 2 of 2 Posts

·
Registered
Joined
·
409 Posts
Discussion Starter · #1 ·
Bit of a read...
A few weeks ago I started to hear a high speed knock/rattle. I assumed it was the supercharger and when I removed it the rattle stopped. Since then I've had the supercharger open twice and I can't find any play in any of the 4 bearings and it turns smoothly. Put it back on the car twice now and always the rattle starts within a minute, usually getting louder as the engine heats up but sometimes it will fade for a bit.

Last week I decided it was the Vortech idler that sits on the mounting plate with the SC. I took it off and the bearing would rattle around inside when I shook it, closed case right? I took out the bearing and replaced it with a new one plus some Permatex Bearing Mount to help fill any gaps and secured it with a new snap ring (the old one had a groove worn into it from the spun bearing).

So I put it all back on the engine and the rattle didn't come on right away but it worked its way up within a few minutes. I've looked the pulley over and allthough I can't really move the bearing inside I can slip a feeler gauge between it and the pulley. Also the Permatex and the oil in the bearing seaped out and flowed in just one direction to the outer edge of the pulley. Does that mean it's off balance?

I don't really have any clear logical thing to pursue right now, something has to be making that noise. Has anyone had this happen? I'd appreciate any help.
 
1 - 2 of 2 Posts
Status
Not open for further replies.
Top