Ford Mustang Forum banner

Status
Not open for further replies.
1 - 7 of 7 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Okay. I have an issue with my ignition, I think. When you turn the key the car starts normal, but then I noticed that none of my dash lights (dummy lights) or turn signals work, if i reach down and move the key back slightly everything comes on. I thought my lock cylinder was bad so I replaced it, but the issue remains. Any Ideas?????

P.S. I already tried to use lock graphite in the sterring colum behind the lock cylinder. No luck....:confused:
 

·
Registered
Joined
·
46,020 Posts
You'll have to take the column cover off and check the wiring to the switch.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #5
Okay lets revive this a little....I think my problem is the ignition gear or lock cylinder gear (either or).The gear at the bottom of the ignition barrle. How do I remove it to check for missing teeth or other problems???:headscratch:
 

·
Registered
Joined
·
172 Posts
ign switch block would be my guess , costs about $10.00 . there was a recall on it years ago
 

·
Registered
Joined
·
9 Posts
Discussion Starter #7
wow... you are the man... problem fixed. now I just can't figure out if something is wrong with the lock cylinder. The door chime goes off even with no key in the ignition when the door is open. Is this normal???? it does stop when i close the door, but I dont think it used to do that :headscratch:
 
1 - 7 of 7 Posts
Status
Not open for further replies.
Top