Ford Mustang Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Well lately when i put my 06 mustang GT automatic transmission into reverse it seems like it shifts hard or jumps kinda into reverse. I was wondering if anyone has this prob, if not what should i do? Sometimes it taks like 3 sec. to shift into reverse, so im just sitting there like WHAT???
 

·
Registered
Joined
·
11,742 Posts
my auto in my 6 does the same thing. mostly if i dont let the rpms come down all the way first ( or if its really cold) so i try to always do that. its once in a while it does it, ive got 89,000 on it. it might have to do with the race tune too, or the other mods. ive done a few flushes and its still working good after me running it pretty hard for 3 years. i think its pretty normal, lets see what others say. :)
 

·
Registered
Joined
·
5,852 Posts
Well lately when i put my 06 mustang GT automatic transmission into reverse it seems like it shifts hard or jumps kinda into reverse. I was wondering if anyone has this prob, if not what should i do? Sometimes it taks like 3 sec. to shift into reverse, so im just sitting there like WHAT???
If you have 30,000 or more miles have you changed the fluid and did a trans fluid flush?
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #4 ·
thanks guys sorry i havent been on

thanks guys sorry i havnt been on the site in a long time but it still does it time to time and it had 48k on it now, and yeah the trans. fluid get changed regularly
 
1 - 4 of 4 Posts
Top