Ford Mustang Forum banner

Status
Not open for further replies.
1 - 12 of 12 Posts

·
Registered
Joined
·
38 Posts
Discussion Starter #1
i have a 1989 ford mustang 2.3L hatchback. Ive already pulled out the old radio & have connected the metra 70 1770 wire harness & i have the kit but its not in. Id like to know how i wire the radio up. There are alot more wires with the metra harness then there are wit the harness that came with my kenwood 645 radio. Id like to know what wire goes to what wire. & if possible how does the mounting kit go in?

The 2nd thing is that i brought component speakers for the front & back of my car (5 1/4 alpine components are in the 5x7 hole in the back with a bracket) there 100 wattts RMS whats a good amp to run to the component speakers? & how did anyone get the wire from the crossover to the tweeter in the dash? & the tweeter hole is 3.5 inches but the tweeter is 1.5 or 1 inches so it will fall through the whole did anyone buy a bracket for it or make there own???

thanks for you advice. ILL upload pictures if you want.
 

·
Registered
Joined
·
185 Posts
That's incredibly hard to explain on here unless u want to read a book. You should google or take it to a stereo shop and let them put it in. Based on your whole question u dnt know a whole lot about putting in your own stereo. Your question involved asking about alot of the basics. U should definitely know how to figure out your hot and grd. And even the speakers. Just my opinion, not trying to offend u!
 

·
Registered
Joined
·
38 Posts
Discussion Starter #3
i was but it looks like its pretty easy to do but, logically it doesnt make sense to pay some1 50$ for 10 15 minutes of work, but ill google it
 

·
Registered
Joined
·
25 Posts
To answer your question on the metra wiring they have a color code on the back of the package these are the colors as follows white wires(frt left)grey(frt right)green(bck right)purple(bckleft)black(ground)red(hotwire)yellow(constantpwr)blue(remote)this wire is only used when installing a amp.orange(illuam.)you dont need caps these wires off blue,orange make sure you zip ties bundle them together match these wires to wires on back of radio once you that take the keys that came with the radio slide bracket off radio take the bracket slide it in space where the old radio was push in the triangle shapes closest to trimming so it will stay in place hook ant.wire in back of radio and silde radio into bracket for as the other stuff go crutchfield.com on how to and amps:bigthumbsupgood luck
 

·
Registered
Joined
·
38 Posts
Discussion Starter #5
ok cool that helped out alot. what did you mean by having to cap wires? & theres a couple wires on the metra wire kit that dont get used apparently right. & im ok with wire caps or use a different kinda connectors for the wires?
 

·
Registered
Joined
·
25 Posts
they are little white cap that you can connect wires with they come in bags of 10-12 at your local auto parts store look like little tall hats just take the wires you're not using and use these this will keep them from touching other wires and burning something out:bigthumbsup
 

·
Registered
Joined
·
38 Posts
Discussion Starter #9
where are these triangle things i just see like thousand slots on the sleeve. I put the sleeve in the mounting bracket slot flush. So i guess your sayin i need to bend one of these slots upward to prevent to sleeve from sliding out right? is the triangle thing your talking about on the top or the bottom or sides?!
 

·
Registered
Joined
·
38 Posts
Discussion Starter #10
do both black wires get grounded or just the1 coming out of the radio? & i bent the tabs out to hold the sleeve but now the radio can come right out the sleeve but the sleeve wont come out of the mounting bracket. ill put pictures up for you
 

·
Registered
Joined
·
1,349 Posts
sounds like your radio is to wide or tall for the opening and not sliding all the way in the bracket to lock in. some aftermarket radios have trim rings that might be just a lil to wide or tall for the factory opening. as i recall the factory radio doesnt have a trim ring around it.
 

·
Registered
Joined
·
38 Posts
Discussion Starter #12
ok well fellas i made that radio fit in because like u said it was pissing me off that it wouldnt work & i refused to put the radio @ the bottom like the stock radio was so i took a dremel tool & sanded the little side lip off both sides, flipped the mounting kit upside down so the eq slot is down bottom & screwed it in!!! =) made it work, tok me a while though! next step installing the component speakers in the car with the amp. & just a curiosity question, could i get 1 12 or 2 12's in the back of the car???!!!
 
1 - 12 of 12 Posts
Status
Not open for further replies.
Top