Ford Mustang Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
39 Posts
Discussion Starter · #1 ·
Installed a JLT Cold Air Intake on my 2013 a few months ago and ever since then I have noticed that above about 5,800 RPMs it gets very raspy. I have Flowmaster Axle-Backs so it's much more noticeable. I was wondering if it could be caused by running too lean because of the intake. Just wondering if anyone has had similar problems? I plan on getting an SCT tuner, but I may be planning on it sooner than expected.
 
G

·
I've often run mine without a tune, and outside of the amazing growl that the JLT has I can't ever recall it sounding raspy. You shouldn't be running lean at all, the car can adjust for the extra breathing it gives you. It'll be a whole different animal once you get the tune though, completely changes the car.
 

·
Registered
Joined
·
6,803 Posts
What he said. I'd double check the seals around everything. When I first installed my JLT I noticed the MAF was situated a little odd because of an imperfection in the mounting surface on the CAI. I VERY CAREFULLY backed it out and re-seated it. This could be the culprit?
 

·
Registered
Joined
·
935 Posts
The car gets raspy above 5k RPM in general, in my experience.
 

·
Registered
Joined
·
39 Posts
Discussion Starter · #5 ·
Thanks for the advice. It is a fairly raspy engine in general, but this extra raspiness comes in like VTEC. It just starts as if someone hit a switch. I'll try to reposition my MAF because it does come more from the drivers side. I'll let you know what happens!
 

·
Registered
Joined
·
708 Posts
The car gets raspy above 5k RPM in general, in my experience.
Though I've only put about 1300 miles on my car, I tend to agree with you. I don't think the raspiness I hear above 5K is due to my intake, I think it's characteristic of the engine itself.
 

·
Registered
Joined
·
1,040 Posts
Compared to a Z or Infiniti G, I don't find our cars are raspy AT ALL. Out of all the modern V6's, I feel like ours is the least raspy by far.
 

·
Registered
Joined
·
39 Posts
Discussion Starter · #8 ·
Tightened my MAF a little, but no real difference from what I can tell. My Flowmaster axle-backs are raspy in the first place. Has any one installed a Ford Racing X-Pipe yet?
 
1 - 8 of 8 Posts
Top