Ford Mustang Forum banner

Status
Not open for further replies.
1 - 4 of 4 Posts

·
Registered
Joined
·
58 Posts
Discussion Starter #1
well i just started my 89 gt hatch just after i replaced my timing cover no water leaks that i could see, however i heard a pinging from one of the driver side cylinders....im not sure which one yet cause it was too dark to really do anything / tell....but can anyone tell me what to look out for when i check it in the morning tomarrow...tnx in advance
 

·
Registered
Joined
·
1,028 Posts
Loose spark plug, loose rocker arm???

Really hard (if not impossible)to get one cylinder to ping, especially at idle unless something is loose and then it would be more of a rattle.
 

·
Registered
Joined
·
108 Posts
89GT5liter said:
well i just started my 89 gt hatch just after i replaced my timing cover no water leaks that i could see, however i heard a pinging from one of the driver side cylinders....im not sure which one yet cause it was too dark to really do anything / tell....but can anyone tell me what to look out for when i check it in the morning tomarrow...tnx in advance
Did you flush the oil,sometimes you get a little antifreeze in the oil pan.
Make sure you drain both sumps and change the oil filter, in case you got any old silcone in the system.
Goodluck
 

·
Registered
Joined
·
58 Posts
Discussion Starter #4
yep, i did an oil change w/ filter right after i put everything back together
i checked the oil, no water it seems....everything good on that aspect....as well as there are no more water leaks....so the primary problem has been solved...
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top