Ford Mustang Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
Hi guys,

I've got an issue with what seems to be part of the front suspension. I have a 2006 with the pony package (upgraded suspension with the sway bars front and rear etc.) and I've developed a knocking when I hit small bumps one after another. On smooth pavement, you do not hear it at all and the suspension feels smooth/normal. However, as soon as you slow down on the side roads and especially pavement with a lot of cracks and uneven surfaces you hear a bunch of 'knocks' almost like something is hitting the inside of the body (but it's not that).

I've been able to isolate it to the front right by pushing down hard on the suspension. I'm thinking (hoping) perhaps a bushing in the sway bar connection somewhere just needs replacing, or it has come loose a little but I don't know for sure.

Any suggestions/help/anyone experience this before?

Thanks guys!
 

·
Registered
Joined
·
68 Posts
I also have a 2006 pony package and mine does the same thing...I haven't fixed it yet, so I'm not sure how, but I have experienced it. Although, does it make the noise in the back as well? Mine makes it in the back, and front like your saying. :frustrated:
 

·
Registered
Joined
·
5 Posts
Chorner,

I have a 05 4.0, mine started to make that clunking noise as well. It turned out that the front anti-sway bar had loosened up a little. If you can get it up on a rack it takes about 5 minutes to tighten.

Chas
 

·
Registered
Joined
·
344 Posts
That would be easy to check, all you have to do is jack it up enough to get under it. Of course, be sure to use jack stands.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #5 ·
Thanks guys - I'll have to borrow a proper set of stands to get under it. I had a feeling it'd just need tightening on the sway bar... I'll grab a couple and report back this weekend.

@Mattcdroid, mine doesn't make it in the back no; but I had previously replaced a couple bushing for the rear sway bar trying to eliminate an annoying squeak which I still haven't been able to 100% isolate. It tends to come and go depending on the weather... strange.
 

·
Registered
Joined
·
27 Posts
Have you fitted strut tower tops? The ones that screw onto the top of the centre camber bolt/damper will bang if your strut mounts are worn or have failed.

You can also experience this type of noise again if your front strut mounts are damaged, worn or failed. Adding strut tower tops just amplifies the noise basically.

I've had the same issues. Currently got some new strut mounts on order and have since removed the none factory tower tops, unfortunately not before they rubbed the paint of the top of my strut towers in the engine bay.
 

·
Registered
Joined
·
1 Posts
Hi guys,

I've got an issue with what seems to be part of the front suspension. I have a 2006 with the pony package (upgraded suspension with the sway bars front and rear etc.) and I've developed a knocking when I hit small bumps one after another.
[...]
I've been able to isolate it to the front right by pushing down hard on the suspension. I'm thinking (hoping) perhaps a bushing in the sway bar connection somewhere just needs replacing, or it has come loose a little but I don't know for sure.

Any suggestions/help/anyone experience this before?

Thanks guys!
I just took mine to the dealer a couple of weeks ago for the exact same problem. It is as you suspect, the stabilizer connections are loose. Or at least that's what mine was. It is hard to diagnose because there is no room to get under the car, and when you jack it up, the wheels hanging down are putting force on the stabilizer connections to make them appear tight. Put the car on ramps or use a platform lift. I'm not sure which exact spot they tightened, but after two weeks the thump is ever so faintly coming back. At least I know where to look this time.

Good luck!!
 
1 - 7 of 7 Posts
Top