Ford Mustang Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1 (Edited)
LED Blinkers Problem - Must've ran out of blinker fluid again - Help Requested

Hello all, I am new to the forum but I need to ask a serious question.

I am having serious blinker problems, I will start from the beginning. I installed sequential tail lights about 3 years ago and they work fine most of the time, then I started having bulbs go out recently. I switched exclusively to LED tail lights and blinkers. I then had a hyper flash problem which means that the blinkers flash really fast because there is very little resistance which is what the stock flasher runs on. So, this week I bought an EP27L that works on timing instead of power values. Well I can hear it clicking at a good rate when I turn the blinker on, but now, NO BLINKERS! This is really frustrating me lately. :frown:

Does anyone here have any ideas on where to proceed from here? I am waiting for a reply from the company to see if maybe their flasher broke before it got here or something but I was hoping maybe someone had some experience with this.

If not for me, do it for my mustang. How could anyone say no to that smile? :smile:
 

Attachments

·
Registered
Joined
·
571 Posts
It sounds as if you have a ground issue. I'd double check the sockets to see what the resistance to ground is? perhaps a wire is loose in the connections you made doing the sequential conversion.

good luck!
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
I may have not explained the problem correctly, I will check for a ground, but I can switch between the original and the new flashers and I get the same result every time. The old flasher works but has hyper flash, the new one, I can hear the blinkers but the lights do not turn on. My blinker fluid is full as well...
 
1 - 3 of 3 Posts
Top