Ford Mustang Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
100 Posts
Discussion Starter · #1 ·
Anyone else having this problem. It has happened to me about 3 or 4 times. Everything goes out except for my foglights. The reason my foglights don't go out is b/c I wired them past my fuse box. ( i have a 4.0 with GT kit and GT headlight harness, etc..) Could it be the fuse box down on the passenger side of the vehicle? Has anyone had this problem and got it fixed? I have to go back to the dealer for a few things and I'd like to tell them what to replace. It is kinda annoying and scary b/c when it goes out, i have nothing. No turns, brake lights, headlights, gauges, etc...please let me know. I took it to the dealer about it awhile ago, but they couldn't find anything (that didn't surprise me). Thanks!!


-Ant.
 

·
Registered
Joined
·
149 Posts
God, I hope these Mustangs don't have electrical problems. I lost my high beams the other night. They went down to dim then when I flicked down to low beams and back to high they were gone. I got home and found the fuse for the high beam was blown. Puzzles me as to why but now I carry extra fuses in the glove box. If it occurs again, I'll take it to the dealer.
 

·
Registered
Joined
·
26 Posts
My stereo went crazy on me a few weeks after I got the car. I was listening to a CD at lunch and when I left the office later that day same CD still in, it kept sounding like it was trying to eject even when I got home and turned the car off I came back out to check on it and it was still doinig the same thing without the key in the ignition. I checked the fuses all were good, I pulled out the fuse and popped it back in and haven't had any trouble since.
 

·
Registered
Joined
·
590 Posts
One of the guys in our mustang club lost all his lights on the dash and not sure what else. Come to find out the fuses under the hood were not all inserted all the way in. Mine were the same way and every other mustang I checked were the same and even the one's sitting at the dealerships.

So make sure you push your fuses all the way in, trust me if you haven't done this, you'll see that most of them will snap in.
 

·
Registered
Joined
·
5 Posts
My lights inside have been doing the same. I took it in and they still have it, but when I get it back, I would like to check the fuses.

Where exactly are they located?
 

·
Registered
Joined
·
590 Posts

·
Registered
Joined
·
2,560 Posts
Hey MS,
I see in your 2nd pic you put the redline tuning lift kit in. I have the ball stud facing in towards the engine. How did come up w/ the idea to face it the other way? Just curious is all.
No fuse/power problems here in 9 months 4,000 miles.
 

·
Registered
Joined
·
100 Posts
Discussion Starter · #9 ·
I kinda figured out whats going on. The fuse box is called a Smart Box. there a leak somewhere under my carpet and water is coming up and getting in the connectors. It has happened before and I took it to Ford and they said they could find anything. Then again it happened in the rain. But, like the time before, it went away. But now this time, it is totally screwed. My high beams are stuck on, right turn was stuck on, now the left is stuck on...what a piece. So, if they can't fix it this time they have to give me a new one. By law they have to. but anyways, make sure it isn't gettin wet on your passenger side could mean bad bad trouble.
 

·
Registered
Joined
·
482 Posts
Ants2005stang said:
I kinda figured out whats going on. The fuse box is called a Smart Box. there a leak somewhere under my carpet and water is coming up and getting in the connectors. It has happened before and I took it to Ford and they said they could find anything. Then again it happened in the rain. But, like the time before, it went away. But now this time, it is totally screwed. My high beams are stuck on, right turn was stuck on, now the left is stuck on...what a piece. So, if they can't fix it this time they have to give me a new one. By law they have to. but anyways, make sure it isn't gettin wet on your passenger side could mean bad bad trouble.
I have the same thing. It's happened twice during wind driven rain. It's unlikely the leak is under the carpet. On mine it appears to be up under the dash somewhere above the fusebox, and drips down soaking the fusebox and pools on the carpet :(
 

·
Registered
Joined
·
1,749 Posts
our NEW mustangs are leaking water???!!! leaky 30K car?! FORD?! WTF?! did you miss a grommet or something?! hope you at least fix this problem with the s197 BEFORE you charge someone 50K+ for the cobra! i dont drive mine in the rain as a general rule, but if i do and it soaks the carpet, im gonna be pissed!

GTNOS>:sterb:<FORD
 
1 - 11 of 11 Posts
Top