Ford Mustang Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter #1
The cable inside the shifter arm of my automatic has broken and i cannot seem to find a replacement cable or shifter arm. I was hoping to find someone on here that has a stock shifter they would part with for a good cause. Please take a look at the pictures for an idea of which shifter I have. Current shift pattern is:

P
R
N
D
2
1

My current transmission is a C4 with a shift kit installed

Thanks in advance for suggestions, ideas, or items of interest:bigthumbsup
 

·
Registered
Joined
·
6,328 Posts
if you can find out if the shifter from a 4cyl auto car is the same,i have one i can sell you cheap..it looks the same from what i can see..i think the cable is still attached..
 

·
Registered
Joined
·
21 Posts
Discussion Starter #3
if you can find out if the shifter from a 4cyl auto car is the same,i have one i can sell you cheap..it looks the same from what i can see..i think the cable is still attached..

The car was originally an 88' 4cyl...it was basically rebuilt for strip use but they never finished and used it for street only...i'm no good with knowledge of automatics as i have been a fivespeed guy my whole life.

The car originally belonged to mustang87wil here on "allfordmustangs" and I ended up with it and all it's problems including the oil-pressue issue he apparently never resolved. Feel free to look at all his threads and see what you can come up with.

Honestly the only part i need is the shifter arm the "T-Handle" fits onto...when you press the button it does not lift the "selector-hammer" on the lockout plate... when i took the "T-Handle" off a short piece of cable came out with it....

At this point i have the bezel removed and i have to lift the "hammer" by finger to switch between gears...

shoot me a pic of what you have ([email protected]) and a price...I'm laid off so i gotta find some stock stuff otherwise I would just buy a ratchet or quarter stick of some sort....:laughlitt
 

·
Registered
Joined
·
6,328 Posts
ok ill get you a pic monday morning..
 

·
Registered
Joined
·
6,328 Posts
email sent,let me know
 

·
Registered
Joined
·
21 Posts
Discussion Starter #6
Hmmmm

email sent,let me know

looks like that one came off of and AOD transmission and the only difference appears to be the angular shifter arm as apposed to my straight shifter arm. The only way I'll know if it works with mine is if you take a pic of the shifter without the bezel and shift indicator (prn(d)d21) on it
 

·
Registered
Joined
·
21 Posts
Discussion Starter #7
I do have a question regarding oil pressure for you, since we basically have the same ride. Only difference is that mine is carbuerated and automatic.

My oil pressure seems to be in the 40's until the car warms-up and i put her in drive. while im driving the oil pressure responds immediately to throttling up and letting off the gas. but waiting at a light the oil pressure seems to sit at 20 and sometimes 0. immediately upon acceleration the oil pressure increases again. the engine was rebuilt less than 3000 miles ago and it wasn't doing this before it blew a head-gasket. i replaced both head gaskets, lower intake gaskets, carb base plate, plugs, wires, MSD coil, MSD dist cap and rotor, and the oil. ive put 3 oil changes (autozone 10w30 and cheap oil filters), one of which included motor flush, to get rid of antifreeze/oil mix. it runs like a scalded dog with no backfires or misses but definitely some valve train noise. the mech. oil gauge currently has air bubbles in the nylon tube the entire length of the tube. Could this be the culprate?

Hit me with any ideas!
 

·
Registered
Joined
·
6,328 Posts
ill get you another pic tonite!! lol

im not really sure on the oil pressure deal,could be a bad sending unit for the gauage? i dont know lol
this shifter is out of a 87 LX coupe roller i bought to build a drag car,had no motor/trans..my car is a 5spd,and i still have the stock OP gauge that seems to work OK..although Ford's factory gauges are known to be junk..

but ill get you another pic later tonite,check back around 6pm est lol
 

·
Registered
Joined
·
21 Posts
Discussion Starter #9
ill get you another pic tonite!! lol

im not really sure on the oil pressure deal,could be a bad sending unit for the gauage? i dont know lol
this shifter is out of a 87 LX coupe roller i bought to build a drag car,had no motor/trans..my car is a 5spd,and i still have the stock OP gauge that seems to work OK..although Ford's factory gauges are known to be junk..

but ill get you another pic later tonite,check back around 6pm est lol

10/4...the gauge in it now is an after market mechanical gauge...only stock gauge hooked up on the car are the speedometer and fuel level...

I have researched quite a bit and everything seems to point to the main bearing clearance as being overly worn. I don't see this as the problem considering the engine was rebuilt such a short time ago. I'm pulling the valve covers today and checking the adjustments on my rockers and making sure there is oil covering everything. this will give me a better idea of what the oil flow looks like.
 

·
Registered
Joined
·
6,328 Posts
i just emailed you some more pics,let me know

sorry i cant be of more help with the oil pressure stuff lol
 

·
Registered
Joined
·
21 Posts
Discussion Starter #11 (Edited)
Didn't get the email

i just emailed you some more pics,let me know

sorry i cant be of more help with the oil pressure stuff lol

my inbox ([email protected]) has no new emails from you within it...:wavey
:worship

yeah,....they ended up in my spam mail and google file 13'd them....just resend the email and i will filter it out....sorry
 

·
Registered
Joined
·
6,328 Posts
sent again..i attached the files right to the email this time,maybe thats why it got filtered out? let me know if ypu have any trouble or if it'll work for you
 

·
Registered
Joined
·
21 Posts
Discussion Starter #13
No go

sent again..i attached the files right to the email this time,maybe thats why it got filtered out? let me know if ypu have any trouble or if it'll work for you
The issue seems to be that all the shifters i have found are 'AOD' and the lockout plate is handled differently. Thanks anyway though.
 
1 - 13 of 13 Posts
Top