Ford Mustang Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
49 Posts
Discussion Starter #1
i have just installed my bbk 62mm throttle body, hooked everything up, started it up, and i have this incredibly loud ticking coming from the engine bay. i thought it could be an exhaust leak, but after looking at videos with people having no headers on and not having the problem, im leaning more towards the throttle body. i didnt match the tps voltage from the stock throttle body, does anybody think this could be the problem? it was making any sounds until i changed the throttle body out and messed with the headers
 

·
Registered
Joined
·
12,664 Posts
TPS is tricky to deal with but BBK had a good video on how to make it work properly
 

·
Registered
Joined
·
49 Posts
Discussion Starter #5
ok so i got the voltage to match the stock tb.....but its still doing it. so i guess im down to an exhaust leak..going to my mechanic this weekend to finish my headers/x pipe hopefully he can tell me what the hell is up with it.
 

·
Registered
Joined
·
57 Posts
I just recently installed the BBK multiple times to try to get rid of hanging rpm problem with it. I experimented with all sorts of TPS settings to try to fix my rpm problem with no luck. But from all this experimentation I don't see how the TPS could have made that noise. The only think I noticed from the having the TPS out of range was to throw error codes.

Also don't see how the BBK TB could causing a ticking sound. If you are up to it you could swap back your stock TB to see if the noise goes away.

Knowing what I know now - I would have recommended against the BBK TB. I am about ready to put back my stock TB after 3 months of fighting the BBK TB and after 3 rounds of custom tuning at a dyno-tune shop to try to fix my hanging rpms.
 

·
Registered
Joined
·
49 Posts
Discussion Starter #7
I just recently installed the BBK multiple times to try to get rid of hanging rpm problem with it. I experimented with all sorts of TPS settings to try to fix my rpm problem with no luck. But from all this experimentation I don't see how the TPS could have made that noise. The only think I noticed from the having the TPS out of range was to throw error codes.

Also don't see how the BBK TB could causing a ticking sound. If you are up to it you could swap back your stock TB to see if the noise goes away.

Knowing what I know now - I would have recommended against the BBK TB. I am about ready to put back my stock TB after 3 months of fighting the BBK TB and after 3 rounds of custom tuning at a dyno-tune shop to try to fix my hanging rpms.
HOLY CRAP MAN!
i might throw my stock one back on and use the spacer that i bought for no reason with it, couldn't hurt to try. its just weird that i have the sound now after the bbk throttle body and its only when i accelerate, when i coast or down shift while breaking i dont hear it, you would think id be able to hear it then if it was my headers or down pipes, right?
 
1 - 7 of 7 Posts
Top