Ford Mustang Forum banner
Status
Not open for further replies.
1 - 7 of 7 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter · #1 ·
Every time I start my Stang (when its cold) the low coolant light stays lite until the car is warm! The rad and overflow are full too but the light stays on while the car is cold can anyone tell me why its doing that?
 

·
Registered
Joined
·
128 Posts
add some more coolent. it could be your mix is more water then antifreeze and the sensor gets cold. try adding more coolent and see if it helps.
 

·
Registered
Joined
·
2,808 Posts
Remove the overflow tank cap from the tank and pull it out. If the sensor is corroded, see if you can clean it up, maybe sand the contacts lightly. OR you can just replace it.
 

·
Registered
Joined
·
3,987 Posts
water expands when it is warm, so it sounds like your just barely low on coolant. When you first start your car the coolant is cool therefor it's more dense, then as it warms up it will expand enough to turn your light off.
I've had a slow leak in mine for a while (still trying to chase it down) but when it first starts to get low that's what my car will do. I just add a little and it goes away.
 

·
Registered
Joined
·
46,010 Posts
I would check the sensor first, they can act up or even stick if there's any corrosion or scale buildup.
 

·
Registered
Joined
·
115 Posts
^^^ I just cleaned mine up and not a prob anymore.
 

·
Registered
Joined
·
3,987 Posts
hmmmm.... maybe i need to try that!
 
1 - 7 of 7 Posts
Status
Not open for further replies.
Top